I cannot re-install the LibreOffice

Hi, I am using Win7 and Chrome browser and I could do with some help as I uninstalled my old version of Libre Office with Revo uninstaller which I have used for 8/9 years, the reason for uninstalling Libre was I actually
thought that the Libre Office was causing a problem with the PC, now I don’t think that it was Libre at all, so I downloaded the V 7.1.8 which goes into Downloads on the C drive.
When the file is opened to install I can go as far as clicking the install button, the file starts to install then stops and I get the warning that the installer cannot find the path, it shows the source as "C:\PatchMyPCUpdates, while this folder is on the same drive and contains the apps/pc programs which Patch my PC usually updates, but the Libre.exe file is not in there it’s in C\Users\Robert\Downloads
I also get Error 1714 showing
Sorry I cannot find an obvious way of attaching a screenshot of the problem,

There is probably a large dose of “Operator Malfunction” involved but if you can help in any way it will be most appreciated, regards Robert

Many thanks for your reply, although the info is a bit beyond my skill level I have seen my problem highlighted in the text, but, I still cannot find any step by step instructions on how to cure the problem, and every time I download the L.O .exe file it will not install, I think because some version 6.0.1? cannot be found, regards Robert

Yes. The link @Hrbrgr gave to General Installation Issues is the first one.

Your previous installation of LibreOffice was not uninstalled correctly. You need to download the installation file for the exact same version of LibreOffice that you had before so that LibreOffice can uninstall correctly. You can download it from the archive (linked from the LO Download page) follow the links and click through the pages to get to the exact version (all the numbers, e.g. and bit version 32 bit or 64 bit) you previously had for your operating system.

Once you have downloaded the installation file then you can point the LibreOffice installer to it when it asks.

1 Like

I think because some version 6.0.1? cannot be found,…

Yes, and the thing is that you can only help if the questioner shares all the important information and right at the initial question.

If you are asked about version 6.0.1?, it is a sign that this old version has not been uninstalled yet or not properly. Here, however, the exact name of the version is extremely important.

You should download the old version from the archive if it is no longer on your computer (pay attention to the exact version name!).
Index of /libreoffice/old

If you have downloaded the old version, try to uninstall it or install the new version.

1 Like

This descriptions can help you:

General Installation Issues (Windows)

System Requirements

Installation Instructions

1 Like

Hi again, thanks for your guidance, I now understand that the LibO did not fully uninstall and I need to install it again, in order to upgrade, I have gone through the motions again and am now being asked to search for v 7.0.2, having tried the link you kindly sent and clicked on v 7.0.2 from the old index I could not find a “Download Button” The download Archive link produced an email form and I got a message stating that the MirrorBrain link was unprotected which I overruled, but still could not find a way to download the v 7.0.2 file from the old index, regards Robert

If you have called the archive page, select the LibO version and klick on Version number.
It is important to always look at the four digit version.
You must keep clicking until you reach the .msi files and click on them to download.

In Example, WIN, 64-Bit:

1 Like

Thanks H, I downloaded v7.0.2.1 and managed to tell it to install in C: program files, it went in and installed from there, unfortunately,

the icon in the start menu is empty and when I click onto the C: program files Libre Office the folders appear but there is nothing inside them, now when I try to login to Libre Office my Dashlane can enter my address and at least 3 saved pw’s and all are rejected, I seem to be making new pw’s every time I visit, it’s getting frustrating, regards Robert

Hi again, sorry still no joy, I have tried to get the Libre installer to install the version I need in the C: Drive but it always goes into a “Users, Robert, downloads” folder and will not install from there, anyway I am away on holiday abroad until the 26th so with your permission I will contact you again after that date, regards Robert

That is the installation for Help, not for LibreOffice.
If the installer asked for (all characters need to match, when you drop the last number you confuse everyone) you need to download either the 64 bit version:

Or the 32 bit (below) depending on what the installer asked for


Hi Many thanks Earnest, The version requested is and I have selected it in the archive, but when I try to download it to either the program files or program files x(64) I am told that I don’t have permission, there is a Libre Office file in “program files” but there is nothing in the folders
Thanks for your help, Ps, I was going to append a screenshot but I could not find the paper clip to affix, and this will be my last session until I return from holiday on the 25th, regards Robert

Enjoy your holiday :slight_smile:

Just as well Windows blocked you, you do not want your program folders filled with installer files and other junk. You need to download the file to your normal Download folder and then just point the installer at that file when it requests it.

Hi, I’m back, and still have made no progress over the last 2 days, are there any printed instructions in guided steps that I can follow through the registry ladder in order to just zap the reg strings of the L.O and then download the latest version, because I don’t think I can get rid of whatever is stopping the latest installation, regards Robert

I think you need to respect the 4 digit version number and whether 32 or 64 bit because the installer needs the exact version of the previous installations to finish removing the old installations. I don’t know where LO adds to registry so can’t help with step by step.

While you are working to uninstall and re-install LO, you can have an alternative installation of LO to do work on. Either

1 Like

The initial answer by @Hrbrgr included the link to FAQ, which mentioned the MS troubleshooting tool. I believe that using that was all that was needed.

1 Like

Hi all, here is an update, and still no joy, I have tried to install a portable version without success (same message) and under HKey Current User I have looked for Libre in the Registry with the intention of zapping the broken strings but Libre was not listed anywhere in the reg, so now it looks like I need another free Office and word processor which is a pity as I have used Libre for over ten years, has anybody any recommendations, regards Robert

For the portable version, don’t try to create it in Program Files, you have permissions problems. Make a folder on the C: drive, e.g C:\portable then when you double click on the installer, navigate to that folder for the installation.
If that doesn’t work then install the portable app to a pen drive on another computer. Then copy the folder from the pen drive to the C: drive on your computer.


Earnest, Many thanks for your help, I did make a folder on C: drive and installed v 7.3.0 of the portable version, and after some prob’s it now opens my text sheets/letters etc and I can work on my text, what problems are left are down to operator ignorance :-) and I am working on that, again thanks for your guidance, regards Robert