I have been trying to create a new database in base but it keeps telling me I have a problem with Java

I have just uninstalled Both Java and LO cleaned the disk drives and down loaded the latest versions of Java 8 SE Development Kit 8 update -102 (64bit) and LO and they still will not talk to each other

Please see the answers in this post and link there also: click here. If still having problems, please provide basic information - OS, LO version and if 32 or 64 bit.


In case not noticed through all the changes, You need to install a Java 64-bit JRE (8u102 is fine) from Oracle (click here).

Also from menu Tools->Options you should see this screen selecting Advanced under LibreOffice:

Use a Java runtime environment should be checked and Oracle Corporation 1.8.0_102 selected.

Your cleaning/unloading/loading really wasn’t necessary. Please see edit in my answer. Also JDK is not necessary just JRE.

Does anyone know the folder location to add Java for Windows 7 64 bit version is please? I have selected them all individually and it reports it as wrong location.

The Oracle links no longer working. I am still unable to find the correct location for the relevant java in the advanced section of options. Please help!

Just checked the link - I see no problem. It links to JRE downloads. Don’t know what your situation is with installed Java location. Where it installs to is dependent upon which Java you are installing - 32 bit for LO 32 bit or 64 bit for LO 64 bit. Since you have 64 bit OS it could be either depending upon which LO you installed.

@TinMan It would help if you stuck with posting comments on the original question instead of many different questions. I don’t understand what you are looking for in Advanced section. If Java installed correctly, the location will appear automatically. Please stick with original question and refer to other if necessary.

Dear Ratslinger. I have checked that I have a 64 bit LO (recently installed). I have uninstalled Java several times and reinstalled both the ‘latest version’ and ‘64 bit Java’ which appear to be the same. If I then ‘Configure Java’ the JRE shows up. If I go into LO Advanced Options it does not, and if I try to add it, I am told that that file does not contain a JRE. Since the thing does NOT appear automatically (in LO) please explain what I am doing wrong. (Windows 10)

@chrisg Sorry, but there a a number of problems with your comment. When you state ‘latest version’ for anything, it really means nothing. Just in LO it can refer to multiple versions. Java is same. Also, it can change from one version to another this hour because of a release. You also state ‘… and if I try to add it,…’ but never state the steps you used to try this. Also not sure what is meant by ‘Configure Java’. This may be best as a new question with more details included.

@chrisg I’m having the same exact problem as you describe in your reply dated 12/21/17 (2 up). I have done the same as you, installed & uninstalled java (Win10 x64). I also saw the jre when configuring. No jre shows in the LO advanced options. We’re you able to resolve the issue, please? Thx.

@Imagine Have you followed the links in my answer(s)? What LO version & bitness are you using? Have you tried to add the JRE using the Add button in the Advanced dialog?

@Ratslinger Yes, I’ve followed the links, thank you. I’m using Version: (x64). When attempting to use the Add feature, I have selected each folder located here: C:\Program Files\Java\jre-10.0.1. It says there aren’t any jre’s in the folders.

While I am using Java 10 (JDK) on Mint 18.3 with LO v6.0.2.x it doesn’t mean there isn’t a problem with Java 10 on Windows (has happened in past with Mac).

Just went & checked out neighbors Win 10 system. Java 1.8.0_131 installed there & Base is working. May give that a try. If it works for you considering filing a Bug report about Java 10.

Versions after Oracle Java 8 are not recognised since LibreOffice 6.
I recommend the use of OpenJDK.

For Windows users, for example: Latest release | AdoptOpenJDK - Open source, prebuilt OpenJDK binaries

Download the MSI file of the JRE (version 11 is ok).

You need a Java 64-bit if your LibreOffice is also 64-bit, or a Java 32-bit if your LibreOffice is also 32-bit.

What do you mean by “Versions after Oracle Java 8 are not supported since LibreOffice 6”? Start with clarifying which version is “6”? In LibreOffice, at least two first digits denote a major version; e.g. v.5.4 is a major release; 6.0 is a major release; 6.1 is equally major release. Then up to (including) version 6.2, the minimal supported version of Java was 5; for 6.3, minimal Java was 6. Starting with LibreOffice 6.4, minimal supported is Java 8; and versions after (i.e., newer than) the minimal supported versions are also supported.

It’s all described in the FAQ.

I tried any Oracle jre more than 8 (9, 10, 11 no works) in (x64) and (x86) and it’s not recognized, only the adoptopenjdk works. Specially if you try to run example database provided in this website (older like 2017 and back)

“I tried and it’s not recognized” is not the same as “it’s not supported”. Had you filed a bug report for that?

Sorry, (replaced supported by not recognised) I will do now… I cannot, I deleted all the jre 9, 10 and 11 from my machine

I do not think so. I am using Oracle Java 8 with LibreOffice 6.4.4 and it is working perfectly.

Try using Oracle Java 9, 10 or 11,