Trouble with LibreOffice Calc and getting the required JRE?!

I’m a beginner to spreadsheets and trying to do some work with macros for an application for a computer bootcamp. I’ve installed Java and keep getting a response that “LibreOffice requires a Java runtime environment (JRE) to perform this task. Please install a JRE and restart LibreOffice.” I have spent a day looking at other forums, but cannot find a solution. Would really appreciate it if anyone could help me get this all set up and running! Thanks!!

LibreOffice will only find a working JRE if it’s the same bits as Libre - both have to be 32 bits or 64 bits.

Edit Check the Tools - Options - LibreOffice - Advanced. Use a Java runtime environment should be ticked. In the list below tick the circle on the far left of a JRE to tell Libre that you want it to use that JRE, even if it’s the only one listed. I’m not sure if Libre by now selects the only JRE available if you turned on Java, but in the past OpenOffice didn’t.

If this answer helped you, please vote it with :heavy_check_mark: (here on the left). That will help other people with the same question.

Thanks for the quick response! They’re both 64 bits. Any other suggestions on what I could check?

See edited reply.

Your edit deserves attention by those with Java problems. It is often overlooked.

Whether to install JRE or JDK, 32-bit or 64-bit depends upon the operating system and LO version you are using. Please see the answer in this post: click here

Thank you! It’s working now. I installed the JDK 8u74 as suggested in the linked post earlier, but this time it worked for some reason. Thanks so much!

[Solved] I got it with jre-8u102-windows-x64.exe after redownloading as 64 bit libreoffice-thanks!

Your welcome, but you placed your response on the wrong question.