Image in docx with wrap set to "behind text" works fine in microsoft but broken in libre

I have a docx file that has an image in a header and the image’s word wrap is set to “behind text”, this is what it looks like in microsoft office. As a new user to this community, I am not allowed to post images, but I’ve posted a question on SO:

Thanks for any help,

UPDATE - added docx file

Test Formatting Letter.docx (34.6 KB)

Screenshots usually don’t help to solve problems, we need the actual document to see why the centered text in the original is no longer centered when opened in LibreOffice.

I uploaded the docx to my original post

I don’t think LibreOffice has the problem here, here is a screenshot from Word 2010

That manual formatting is not recommended, not even by Word. You can’t centre text by indents and spaces and expect any consistency. If you look again at your linked screenshot you can see the text is not properly centred there either.

Try this
Test Formatting Letter80011_EAl.odt (36.2 KB)

1 Like

Indeed that is a problem, since the file obviously uses compatibilityMode=15 (Word 2013+; tdf#131304). Please file a respective bug and put it as a blocker for the mentioned tdf#131304.

I did that myself: tdf#150192

1 Like

When you are new to word processing, it really pays to be a little lazy. Before you do a lot of hard work to achieve some effect, first think of rule nr 1: if you can be sure that what you want to do is done a lot, the developers will have added a simple solution for it. Look for it. Make a test document, apply all the formatting that you can, one thing at a time, and note the effect. It helps a lot if you know where to find things that you may need later on. It’s a funny thing to do, and it doesn’t cost as much time as looking for it when you have to meet a deadline.


We have a 1,000 of these documents that have already been generated that we are trying to use with libreconv, so I’m not looking for advice on how to fix the document, I’m looking for how to get it to look like it looks when you open it with microsoft word. Sorry I should have been more clear.

It seems very dubious to me to want to convert 1000 document.
Leave the original documents as they are.
If you need to edit a document in LibreOffice, make a copy of it.

However, if the intention is to archive the document, you should export the original document to PDF’s from MS Office.

However, you are welcome to explain what exactly is the purpose of your plan.

@Hrbrgr: the stack overflow article that is mentioned in the initial post mentions that the conversion is to PDF, so it’s perfectly valid scenario. (Indeed, it’s pity that the information about the question has to be obtained here and there, not everything explicitly stated in the initial post.)

The only correct (and reliable) way to have a proper output when the program has a bug is to fix that bug; as I mentioned above, I already filed the bug.


thank you for paying such close attention.
Sometimes is unusual to follow the posts because they are not in order.
I was only irritated that OP in his introduction speaks of one file and now there are a thousand.

thank you, i appreciate you doing this

the point is that i am not asking how should i modify my document so it looks correct in libre, my question is why does it look one way in office 365 and another way in libre. i’ve already said “sorry” so i’ll say it again, i’m sorry for not including this in the original post.

it’s a template document that was used to generate 1,000 documents with mail merged data. i was trying to reduce the problem to avoid adding confusing and unnecessary detail. thanks for your help so far.

It is understandable that rules used on this site might be not obvious to newcomers who didn’t read them. So for your following posts: indeed, it’s possible that not everything got into the question from the first attempt; in that case, when you are asked for more details, instead of adding clarifying comments, please edit the question itself, to have it formed appropriately.

This way, everyone seeing the question can see the whole picture without having to go through all the comments.

The reason the document looks differently in the two word processors is because 1) it’s very badly formatted (technically, not esthetically) and 2) compatibility doesn’t mean that files are converted pixel-perfect. Many people who come here for help have the highest expectations about compatibility. It doesn’t work like that. The best way to ensure that the conversion doesn’t give an enormous headache is to keep the formatting as straightforward as possible, so use single tabs and single spaces instead of using lots of spaces to get a good-looking indent. But that should be done in the template, of course.

As to your second point: most people who come here for help, want a fix for their problem, not only information about why the problem occurred. We probably assumed too readily that you are one of them and started looking for solutions.

On the long term: Wait until the bug filed by @mikekaganski is fixed by somebody.

Short term: I assume Microsoft can convert its own files to pdf, without needing LibreOffice as “extension”.

Workaround: As this bug seems to be grounded on the compatibility-mode for older versions of MS-Office, the problem maybbe solvable by getting rid of this compatibility mode. But I don’t know how to do this in MS-Office.

Your header data will never be correctly centered because you have an awful mess of paragraph indents (left side + first line indent). Nearly every paragraph has different settings. You have added tabs and spaces in a feeble attempt to compensate for the incompatible indents with no success.

How to fix

Ideally define a common paragraph style for your header data. If you intend to save as .odt (highly recommended), just style with Header paragraph style. It is preconfigured for 3 “blocks” with the middle one centered in the line. Just add a Tab at head of your paragraphs (after removing the existing spurious prefixes, tabs and spaces).

Otherwise, remove your tabs and spaces and center the paragraphs.

Regarding the image, the setting equivalent to “send it into the background” is wrap mode Through. When you choose this setting, the image no longer interferes with text.


Confirmed. For this case, just delete the leading spaces, select the header text, remove the direct formatting (press Ctrl+M), then apply the Header style (always the thing to do with header text), modify the Header style to have your text centered (Alignment tab).

1 Like

Not necessary: default configuration for Header has a centering tab at the center and a right-align tab at right. Consequently, a simple Tab preceding header text is all that is needed to center it.

1 Like

If the user changes the position of the centered tab, the text will not be centered.