Images SHRINK itty bitty when exporting a text document to PDF

I am creating a document where I am dragging pdf snippets I have created using LaTeX into a LibreOffice writer document (for the sake of this application it’s simpler than just compiling the entire text in LaTeX, or it was until now…). Everything looks great, until I export it to a PDF. Then everything is in the right place, except the pdf snippets I had previously dragged in are minuscule. If I zoom in, the vector nature is maintained and I can see everything fine. I have tried adjusted every conceivable option in the pdf export prompt, and I always get this same result. Any idea what I can do to fix this. Thank you!

I’m no native speaker of the english language, so “itty bitty” may be a very precise description of something.
If not I recommend to start with the help to this site and the chapters “You can help us understand you better.” And “More details”:

Also uploading the start of your file ( one page ) wich includes one of these pdfs for inspection may help.

Thank you, I have uploaded here the first page of the document:
firstpageoffile.odt (576.5 KB)

Suggest you change text in document. There is a missing l in:

Gory be to the Father

in the English response.


very small or tiny.

1 Like

Have you looked outside, lately?
:laughing: Thank you. Trust me, there are many more.

Though the images seem to be embedded in your document, they don’t display here (LO, Fedora 37). I made sure display was enabled. Anyway I have no “place holder” as Image n like when display is disabled. I can’t either “Edit image with external tool”: I get a blank image. I suspect an issue with the image. Have you special extensions to handle such images? Encoding says it is SVG, not PDF.

Interesting. Note that PDF inserts are implemented using PDFium; I wonder if not having that library installed on system would disable that functionality?

I have no extensions; I just installed the LibreOffice software a couple of days ago. I am just dragging PDFs onto the page I’m working in. Also, if it makes a difference, using macOS 11.5.1.