Import EPS on Writer won't show the image

Dear libreoffice experts,
I am facing a very strange problem (I think this came up with the latest update, version 1: ). I have a Fedora 20 OS and let me describe you the problem.
For a long time I import EPS files to Writer as graphics and everything worked great! Today (I think it 's the first time after the update to the latest available version), I noticed that most of the EPS I had improted, is not shows! Trying to find what goes wrong, I imported an older EPS file and the result was to be loaded but a bit strange; saying strange I mean that a few letters were in different order etc (the EPS file looks right in Evince).
Could you please inform me if there a solution on this problem?

P.S.: I tried to downgrade to the previous version but unfortunatelly the operation could not be completed. A solution is to uninstall LibreOffice and reinstall the previous version, but it would be great if another solution exists.

Thanks a lot!

Note that the term “import” implies using LO to open, and thus convert, a file in a non-native format. For an image file this would imply the use of Draw. It appears that you are inserting an image into Writer (either via Insert > Image or cut/paste). There is no native EPS support in LO so images inserted in this manner may have worked in the past by coincidence.

Hey, thanks for the comment! Yes, exactly I insert the image via Insert > Image but I am doing this for a long time and everything worked fine!
Also, I now noticed that on my laptop this problem does not exist. The LibreOffice version is the same and it imports the EPS files fine! So, maybe I should reinstall it ?

Reverting to a prior version may be the only alternative if the regressive behaviour is consistently repeatable. Report fdo#67464 is the enhancement to get native EPS handling implemented. Bug fdo#67634 may also be related.