Impossible to add JRE (LO 24 or 7.6, MacOS 14.4.2, Apple M2)

Hi there, I’m very frustrated installing LO with Zotero in a class room that has Mac Minis with MacOS 14. I tried both the latest LO 24.2.3 and the previous 7.6.7, same error. LibreOffice fails to detect the Java installation. By now, I tried three JDK versions, JDK 21 from Oracle, JDK 17 from Oracle, and Temurin (Adoptium) 21. None of them is automatically detected, although obviously correctly installed (I can run javaor javac from the terminal).

$ java -version
java version "21.0.3" 2024-04-16 LTS
Java(TM) SE Runtime Environment (build 21.0.3+7-LTS-152)
Java HotSpot(TM) 64-Bit Server VM (build 21.0.3+7-LTS-152, mixed mode, sharing)

But when I open LibreOffice, I just get the ominous error message:

JRE Required. LibreOffice requires Oracle’s Java Development Kit (JDK) on macOS 10.10 or greater to perform this task. Please install them and restart LibreOffice. Frequently asked questions - General - The Document Foundation Wiki

And I go to Preferences > LibreOffice > Advanced > Java Options, the list of installed JREs is empty. I am trying to manually add, going into /Library/Java/...:

And trying every possible sub-directory, obviously starting with Contents/Home, e.g. /Library/Java/JavaVirtualMachines/jdk-21.jdk/Contents/Home.

But no matter, what I do, all I get is this lousy message:

The folder you selected, does not contain a Java runtime environment. Please select a different folder.

If you can’t get Java working: It is only used for Base, special internal HSQLDB. You could also use internal Firebird. It won’t need Java. ReportBuilder and some wizards in Base wouldn’t work without Java, but you will get a working database without.

Java seems to be needed to use the Zotero plug-in …


Before the download:

Please kindly verify if the LO version is either 32 or AMD 64. Then go to Option menu—>Advanced.

For your info LO 6.0.7 runs wit JRE- 11.


Are those versions of Java x86_64 or aarch64? You need the latter if you are running LO for aarch64e.

Everything is AARCH64 obviously, otherwise you wouldn’t be able to install the .dmg (macOS gives you an error message when picking the wrong architecture). I can run LO and I can run java(c).

@sciss : Following the link you posted I see:

LibreOffice releases available from Apple App Store don’t include Java support at all, because apps distributed in the App Store are not allowed to depend on optional functionality like Java.

Which version of LO did you install?

By the way: Zotero seems to be written in JavaScript, not Java.

I see some other threads where others have encountered similar issues, but all I can say is that Java is recognised on my macOS M1 system by LO, whether 7.6.x or 24.2.x

1 Like