How can I install a Java Runtime Environment in LibreOffice on MacOS?

Hi there,

I tried to install the Zotero plug-in in Writer automatically (Zotero / Cite / Word Processor…). It failed. I therefore ask for help on the Zotero forum, updated my LibreOffice version (now: because my MacOS does not support the latest version) and tried once more. Same result. Then I follow the instruction here:

It appears that I have no Java runtime environment. I therefore downloaded the JDK22 installer for Mac. Nothing changed. In Libre Office / Preference / Advanced, there is no Java Runtime Environment.

So my question is: how can I install JDK to be able to use the Zotero plug-in??

Many thanks!

Check first, if the jdk you downloaded is supported by your unknown version.
Usually I’d check in the release notes of LO, what was required then (at the end of release notes), but actually this covers only OS, not Java.
JDK also have to use the same architecture as LO, but as you use an older OS-version, I guess you have an Intel-CPU, no ARM/Apple-M1,M2 etc.
Several people had problems with java on Mac, but the topic seems solvable.

Thank you @Wanderer ! read the post you linked to your message and I installed JRE 15.0.2. The installation succeeded as you can see in the screenshot of LibreOffice / Preferences / Advanced. But still, I cannot use Zotero. I am looking for help also on the Zotero forum.

My Mac version is 10.14.6

Sometimes, it’s the version of Libre Office. Whichever version you are running, go to preferences, and then to advanced. At the top of the box, it will say “Java Options”, with a box to check that says “Use a Java runtime environment.” Then, in the box below, it will show you if LibreOffice has found the Oracle app and allow you to add it. The previous versions of libreoffice could not find Oracle for me, but the latest version…24 or 24.2, found the three latest for me, 18, 20.0.1, and 22. it shose 20.0.1 and is now working fine. I have a Mac Mini with an M1 and have the latest Mac OS, Sonoma 14.5

My Mac is 10.14.6 and apparently the latest version of LO 24.2 didn’t work when I installed it. So I got back to LO 7.5.6. It can find Oracle JRE 21.0.3 but still I cannot install correctly the Zotero plug-in.