Connecting to Java on Ventura 13.2.1

I run Ventura 13.2.1 on an M1 Mac. I have downloaded both a JRE and JDK. I can’t make either of them work. How do I connect them to Libreoffice? I know the path should be Library/Internetplugin.plugin/contents/home. I open LibreOffice, go to Advanced, go to Library/Internet Plug ins, then it tells me that the JRE is not there. When I open Library separately, the Javaapplet is there. And I have installed JRE-8u-361.

1 Like

Can that help?

How to install Java (JRE/JDK) so that LibreOffice could use it? - Using macOS

Unfortunately, no. The wiki article helps me download the right JRE. But when I go to advanced, Libreoffice cannot find the applet. It goes to (Username)/Library/Internetplugin.plugin/contents/home from the user name, but the applet seems to be under MacIntoshHD/Library. There does not seem to be any way to connect.

Some of you Mac-people were successful:

I am also not able to set a JRE in LibreOffice (AARCH64) on macOS Ventura 13.6.

This works on my Intel Mac running Monterey 12.7 and LibreOffice where I am able to use OpenJDK from Amazon Corretto 17, 11, or 1.8 (at /Library/Java/JavaVirtualMachines/*/Contents/Home).

This appears to be a problem LibreOffice. I have gone so far as to grant LibreOffice full disk access via System Settings, but still no luck.

You’re using the wrong path.

For some reason, Oracle still installs the JRE on a user level to the internet plug-ins folder, probably because it presumes that the JRE will only ever be used with internet browsers.

LibreOffice stopped using the internet plugin folder ages ago.

The JDK needs to be installed into :


This is a system folder and you will need admin privileges to either copy the JVM folder that you have previously unzipped elsewhere, or if an installer is provided, to allow the install script to install the corresponding PKG from a downloaded DMG (Oracle).

Not all JDKs are recognized after installation because the allowed minimum version is hardcoded into LibreOffice. Try with a JDK17 or JDK18, rather than a JDK19, and also, you might have to try various JDK providers until you find one that is recognized by LO. For what it is worth, I have an Oracle JDK18 which is recognized by LibreOffice.

Also note, and this is probably the most important thing, if you are using LibreOffice from the app store, then no amount of faffing with JDKs will work. Quite simply, all Java Code calls have been removed from the product distributed via the app store, apparently because it is one of the rules of being allowed into the store in the first place.

If you need Java functionality in LibreOffice for Mac, remove the app store version and download LibreOffice from the LO website download page.

1 Like

Thanks so much for this comprehensive answer. I will try this in the next couple of days…with fingers crossed.