Impress Embed transition sounds

I’ve created an Impress presentation with some transition “other” sounds. It works fine on my PC. When I export to PowerPoint format or even play my native Impress file on a different machine using Impress, there is no sound. Apparently Impress calls other sounds from the file system rather than embedding them in the presentation. How to I make my presentation self-contained, and fully portable?

The transition UI does not include the “link” box to check or uncheck (if unchecked, you are embedding). It’s simply a file navigator to the file system were you can choose a file.

Ah, okay. That’s what I guessed.

Hi @marietta_greg,

I’m not sure about the mechanism to add sounds for transitions in Impress, but if they’re files on your local system, perhaps you could use the same option as when embedding audio/video into an Impress presentation?

I have tested embedding sound (Insert / Movie and Sound) into a slide, saving the presentation and attempting to play it on a different machine. Still no go. No sound So apparently Impress does not support creating a self contained presentation, playable on a different PC.


Thanks for the additional testing. Here are some bugs that might be related/similar:

  • fdo#44223 - No sound in presentations saved in .pptx format [FILESAVE, FILEOPEN] - NEW
  • fdo#33156 - Missing information that Movie / Sound will be linked, not embedded - NEW

This one seems quite spot-on:

  • fdo#57291 - Embedding audio files used for transitions - NEW

For now, I suggest that you make comments on any/all of those bug reports that are relevant to your situation. I can’t make any promises about when the developers will get to a particular bug, but it’s good for us to know how many people are being affected by a particular problem.


Hi @marietta_greg, just checking-in for an update. Have you had a chance to review the bug reports?