Impress: Image filter not found


I just upgraded to Fedora 40 and libreoffice and opened an existing impress(.odp) presentation and some of the images are not displayed, yet have a outline border displayed. With the cursor within this border and selecting the right menu option ‘Edit with external tool’, the external editor displays these image(s) fine. All the images in this existing file were inserted using Insert/Image…, and the file can be opened on another computer, with a much older version of LO, and the images are displayed within impress fine there.

As a test, I opened an empty impress, i.e., created a new presentation without a template, and did Insert/Image… with one of the images in question. I received a popup message stating ‘Image filter not found’. I then tried copying said image to the clipboard and pasting into impress and this worked with the image displayed.

All of the non displayed images are TIFF and are large. The displayed images are png, and tif. I have not used an image filter or compressed the images.

Are there image filters that may not have been upgraded/installed or a configuration default that was changed between releases?

In case this has anything to do with this image issue, another existing .odp file now does not have a (the same) background color.

Thanks in advance,


There are many specifications for TIFF images covering colour mode, bitness, compression, etc.

If the TIFFs displayed OK in an older version but not in the current version then it might be worth posting a bug in your distribution’s bug reporting tool if you aren’t using a LibreOffice release from the LibreOffice site.

If you wanted to post a reduced pixel count TIFF (but still same colour mode and bits) that won’t display on your Impress, I could see if it displays OK on my Windows versions.

This is a version from a parallel universe. In our world, the last and the released version of 24.2.3 branch is It’s best to open HelpAbout, and use copy button to have the correct and complete version information to paste wherever you want to mention it.

Sorry, I did not see the copy button, did it manually…

Version: (X86_64)
Build ID: 420(Build:2)
CPU threads: 12; OS: Linux 6.8; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded