In Base, number format not showing values in decimal places

When I enter a value containing a decimal value in a number data cell and click off the record (66.66), the decimal value changes to (66.00). I have tried the various number formats and it has not helped. I am using libre on my Mac computer and trying to enter currency values but I need the entire value not just the whole dollar values. I there a setting that can correct this problem. i have tried number and decimal types with all the options but no luck in getting values to show decimal values.C:\fakepath\Screen shots.docximage description
I uploaded the file as an image and a file (not sure which will work.

I sincerely doubt that you have tried “all the options”. If you use decimal data type and specify two decimals, Base should store and display two decimals.

Note that there is a distinction between decimals in data type (which specifies how many decimals to store) and decimals in the format (which specifies how many decimals to display). If you don’t request that decimals be stored but use a format with two decimals, the result will be as you indicated.

Have set both the data type and the format type but no success. I even downloaded a sample data base that had a number field and it worked until I added another number field to the table and then both the existing and the new fields only showed whole numbers not the decimal places. (they all changed to .00)

Have set both the data type and the format type but no success.

  • Data type set to what, exactly?
  • Can you list all the fields (names and content) in the dialog below table fields list (where you set the data type). A screenshot may be useful.
  • Format set to what, exactly?
  • In the Field format dialog (click the ... button at the format preview field), what does it say in the Format code field?

Not sure how to upload to this site. I have uninstalled Libre Office and reinstalled it, but still have same problem. I have set two decimal places in table edit format and in table open column formats. If you can direct me on uploading file it would probably help. Thx

If you can direct me on uploading file it would probably help.

Edit your original question (see the pencil-Edit link just below the question text). Use the paperclip tool (above the edit pane) to attach a file to the question.

I will upvote your question, which raises your “karma score”. With a karma of 1, you may not have sufficient permission to upload.


Your images of the table Field Properties are not showing the information one would expect to see. What Database are you using and what specific version of LO is used?

I am running on a Mac computer using MACOS High Sierra 10.13.6. LO Version DB HSQLDB.

I downloaded a different version of Libre Office (Version: and now I am seeing the correct field property windows and I am able to set the property to 2 decimal places and it works Ok. Looks like a bug in the newer version of LO. Thanks for your help.

I was using the latest version of LO ( also had problem with pasting anything in SQL editor box… I downloaded the previous Version: Now both problems are solved. Looks like bugs in newer version.

Please edit your question or add a comment. @keme has explicated how to upload.