Increase Font Size of Calc Formula Toolbar in LibreOffice Version 6

The upgrade to LibreOffice version 6 seems to have eliminated the ability to adjust the font size of the Calc Formula Toolbar. It needs to be increased to improve legibility. The ability to modify the size of the formula toolbar, in prior versions of LibreOffice, was previously addressed in: How do you increase fontsize on the LibeOffice toolbar and dropdown menus? Apparently that answer no longer applies to LibreOffice version 6. The scaling option appears to have been depreciated. How can the font size of the Calc formula toolbar be increased to make more legible?

The change happened in 2016 (this commit), and was introduced in version 5.3. It is because the feature to scale UI elements is a standard feature of all OSes and desktop environments, and LibreOffice obeys the OS settings. So users who need to have enlarged UI, should use OS-provided means to do that.

Links that Google provided:

What does “So users who need to have enlarged UI, should use OS-provided means to do that.” mean? How can the font size of the toolbar be increased?

You didn’t provide details about your OS. As I said, you should use your OS features to scale the UI, but I have no means to tell you how it is done in your OS without knowing which is that (and even when I know, there’s no guarantee that I know the details about that specific OS - you should consult your OS manuals).

My apologies. Linux. Specifically Ubuntu 16.04

Found the answer. Need to use the Tweak Tool. Fonts → Scaling Factor. See: “How do I change fonts and adjust their size?

@mikekaganski. I have Kubuntu 18.10. KDE Frameworks: 5.50.0. KDE Plasma v. 5.13.5. How do OI change the font size of the formula bar? None of the options in System Settings->Fonts work

Use xrandr --dpi <dpi> to tune default font size in WM-only Linux systems. See my answer.

I’m commenting here because I searched the web for months looking for a solution, and I grew tired of looking.
As far as I can tell, it seems there is no solution in sight for recent versions, and since the Option->View->User interface disappeared, there is no way for users to change this setting.

For all those with reasonably modern monitors (i.e., newer than 2015) or all visually impaired people, it is a serious usability issue.

The suggestion of Steve R. above is a quick fix but it’s a fall-back, not a real solution (it does not work for people using desktop environments other than Gnome, like KDE on Linux or Windows, for that matter).

I’ve re-opened the bug discussing this, I hope people will comment and provide feedback for it.

Don’t know about other OSes, but surely it’s possible for Windows (I did that). Also there are links about KDE and macOS. Please don’t declare what is obviously not true.

Thanks for taking the time to reply here.
That’s great, actually! I wasn’t able to find any solutions for KDE, that’s why I commented. Could you please share it so I can test it?

Did you read my answer above with the links? or did you try them, and they didn’t help? then first mention that, and describe what was wrong.

My bad, I thought you were referring to something different.
I’m sorry if that made you nervous.

As I mentioned in my comment, I’ve tried that, yes, and does not work for KDE. Also, by keeping googling, I found that the problem is present also on Macs.

I’m open to any suggestions, if you have any.

In case somebody is looking for more information, here’s the correct bug report, where they mention the issues of setting the font size across different DE’s.

I am using Galliium OS on an Acer 14" Chromebook, CB3 431. I recently installed version 3.0 beta. It is based on Xumbuntu 18.04. Working OK, except that in LibreOffice the toolbar icons are tiny and the text in the data entry window (input line) as well. Very hard to read. I can change the size of fonts in the spreadsheet cells. I can drag the border to increase the height of the input line, but the text remains tiny. I have gone to Tools, Options, View and changed the Toolbar Icon Size. If I put it to “large” it’s somewhat better but still too small. If I put it to “Extra Large” the icons disappear and are replaced by grey patches that extend laterally off the page.
I have gone into the settings menu of GalliumOS and changed the icon size and font size for menu displays. But it does not effect the input line or icons on the toolbars in LibreOffice.

Looking for suggestions.

In case of WM-only Linux systems (i.e. with i3), you can just use xrandr --dpi <dpi> to set the default size of fonts. Increase <dpi> to get a bigger font. (You need to restart LibreOffice.)

In my case 100 matches the default size (which was quite small in LibreOffice’s UI), and 125 works out quite well.

Btw, I have found this piece of information here: https://bbs.archlinux.org/viewtopic.php?pid=1642494#p1642494

For Mac users, certainly those staying with macOS 10.12.6, AAPL’s Sierra, my Sys22 (I started with System 0.9 in the 128), the long deprecated Mariner Calc redraws the spreadsheet AND the formula bar at a change of the app font in the app’s preferences. So it’s possible to do it in a spreadsheet, just that perhaps herd mentality has taken over, and 'that’s how everybody’s doing it now".

Calc never took off for Mariner - not pretty enough? - I never bought it either, but I did keep a copy, and I find myself using it more and more for its pure simplicity, and for it not butting into what I am doing. I long ago gave up on Excel - except very occasionally when in frustration with current follow-the-mob spreadsheets’ behaviours, I fire up the Pismo (circa 1998, G4 PowerBook) to work in Excel 8 again, for it’s relative clarity.

I offered to buy a copy of Calc from Mariner - they no longer have it - they donated me a licence! Lovely people. Just maybe, it’s possible to have them declare it open source?

In the meantime I continue with LO7 for it’s great tools, but hey, I’ve still got the old versions, and maybe I can stop messing with my inverted reading glasses when I’m building new work, and have a decent sized font in the formula bar so I can tell a period from a comma, and and an I from a 1.