inserting images in writer is a joke!

I am trying and failing to simply put two images one after the other into a writer document. This is a joke! it can’t be this hard. Seriously!!! They keep reordering themselves and i can’t control them as hitting enter underneith actually moves the image DOWN which is completely stupid. This should be easier. I am not trying to do anything complicated just insert one image after another. Instead i have lost control of my document!

Your posting makes no sense and uses offensive language. Besides, it is not a question. So, get a downvote, cool down, read these guidelines and ask a good question.

I’m currently struggling like hell to put pictures in a document and I totally agree with your frustration… It should “just work” without having to read dozens of manual pages with abstract concepts. Software must just work.

You’re out of line and have gone blind because you detected what you call bad language, so that makes you into a joke.

Inserting images is very easy and not a joke. The problem is you haven’t bothered to learn.

Read the chapter in the manual about images in Writer and make sure you understand Anchor and Wrap options.

Do not anchor two images to one anchor.

See [Tutorial] Some useful hints on using images

Reading the manual should only be done to execute complex operations. The basic ones should work out-of-the-box without having to integrate complicated concepts. Inserting a picture in a document is a basic one and unfortunately the behavior is kind of fuzzy.
That’s basically what makes the difference between a software designed for general public and software designed for experts.
And that’s the sad story about why people continue to pay for Microsoft Office instead using a 100% free software developed by the community…

Easiest solution: hit return before importing the 2nd image.

Not so easy solution: change the anchor type(*) to ‘as character’ and put a space in between them.

(*) Change the anchor type:

  1. insert image
  2. right click on image
  3. choose “Anchor → as character”
    (you must repeat this for each image.)

LibreOffice SHOULD deal with 2 images in the same place by converting them from the default “to paragraph” anchor to “as character” anchor, but whether that’s a bug or just incomplete programming or a feature to have the app allow multiple images in the same anchor point creating havoc with image placement—is for people above my pay grade.

Writer handles images anchored to the same object (e.g., paragraph/character) without problems. It’s just the default image setting to allow overlap may make several images to be above each other. And making images automatically anchored as character is not a correct thing. Disallowing overlap by default might be a better change, if someone files that request.

Please do not implement stupid methods and then expect someone else to tell you that you need to fix it. Anyone in normal head-space knows the current state is unusable. It’s completely counter-intuitive.

@snovotill: “counter-intuitive” is only a word to hide yourself behind your routine.

Writer is a tremendously powerful document processor, bridging partially the gap with desktop publishing applications. As it is powerful, it doesn’t restrain author creativity and does not impose any strict procedure over image insertion.

I admit very easily that getting predictable, reliable and reproducible placement of images (or more generally frames) is one of the most daunting tasks in Writer. This is the price to pay for the power (e.g. automatic reallocation of frames when you edit text) and versatility.

You must accept Writer is not based on common (rather not fully rigorously specified) principles and has chosen another path. Writer is style based. Styles are ubiquitous. In particular, images are inserted as frames and frames are controlled by frame styles. However, I repeat, taming frame styles is not immediate.

But formatting your images through styles is much more reliable than trying to manually fix image hick-ups. Learn how to master styles.

Manual formatting (aka. direct formatting) was provided to ease transition from other apps, like M$ Word, for simple documents. For “complex” documents, forget Wrod procedures which are either manual (because there is nothing beyond paragraph styles) or M$-imposed-on-you (to simplify your life, they say).

No. Counter intuitive means that you have to RTFM or click around when you are trying to write a quick and dirty document, and that’s exactly what this is.

Do you really think you can use ANY software without RTFM, at least skimming over a few pages?

As you have obviously been using Microsoft Word for a while and are used to its idiosyncrasies, you might find it useful to change a setting in Writer to imitate Word’s default. This works only for LO version 7.x.x.x.
Click Tools > Options > LibreOffice Writer > Formatting Aids and under Image change to As Character