Installation of 6.1.0 in Win10 fails "The system cannot open the device or file specified."

There are various “Internal errors” which follow, usually 2755 110
I have tried running from Admin Cmd.
I have tried swiching Defender Controlled folders.
I have verbose logging but it’s still unclear what’s happening.
I had 6.0.5 installed and was hoping to update. I uninstalled and now the old 6.0.5 MSI fails likewise!

Since found due to particular security setting.

look here:

Otherwise, try turning your virus protection off.

Most of these bugs are known in this forum. Enter in the search bar, e.g. “Error”. You will be given many answers.

Sorry, ebot, it was neither antivirus nor “smartscreen” download protection.
Neither of those would have reached the “device or file” error, after offering the desktop icon.

Perhaps LibreOffice should (at least try to) translate windows errors like 2755 ?

It is not up to LibreOffice to translate or interpret OS error messages. LibreOffice would have to handle many OS types and versions. The USER has a decision-making power what he wants to use and also a responsibility. There is no 100% perfect technique.

Well, then, perhaps a warning to move the MSI from Downloads to Windows (requires a permission) if using Win10-1803. That is if I’m right - I haven’t fully researched it. Perhaps a tweak to the MSI would not require a folder with SYSTEM rights? Who does the Win10 installation build? Can you put me in conact with them?
He’ll have Win10-1809 to deal with soon!

You always need rights to access your computer. These are different. To install programs you need higher rights than a normal user. Access and action rights on the computer are assigned by the OS. It is best to buy a manual for your OS and study how to set up rights.

In case you’d forgotten, I stated that the rights have changed from Win10-1709 to Win10-1803 in such a way that the ordinary user is no longer able to install LibreOffice easily at all. I just hope the humans in the forum read all this!

I got it installed at last!

Since writing the below, I have discovered that MOST 1803 installations have SYSTEM in all the User-area folders.
I think I must have done something to remove it on both systems I tried, perhaps a security measure included in something.

I had to add SYSTEM with full control to the Downloads folder with the MSI
This is a fairly new Win10 installation so it seems the defaults have changed in 1803.
Am I wrong?

Another MSI app has failed since, on another Win10 1803, with more verbose information.
Perhaps LibreOffice should change to EXE?

Or (at least try to) translate windows errors like 2755 ?

Have you tried “unblocking” the MSI?

That releases the “smartscreen” block. My MSI had started and been through two forms.

That doesn’t mean anything. The block is a special “mark” (in a form of alternative file stream) of “untrusted” zone which was the source of the file. MSI installation works in two phases: impersonated (when msiexec is run under launching user’s account), and privileged (when it’s run from system account as a service). In the second phase (which is started after “two forms”) it checks different security settings, and might refuse to run what passed first stage. Hence my question.

Well, my MSI has no “Unblock” tickbox. I just tried to use it again from a folder without SYSTEM and it failed just the same, though this time asking for escalation after the desktop icon. BTW does “ebot” ever give up? (see above) Can you connect me to the MSI developers?

I was using it to modify this time, just remove a language.

Thank you for the effort to discover the possible source of the problem. Unfortunately, I wasn’t able to reproduce using a new virtual machine with a fresh Win 10 1803 installation. Downloads grant SYSTEM full access by default there. Maybe you’ve moved it somewhere?

Can you connect me to the MSI developers?

I am one of them (from your comment to ebot above, I take “MSI developers” as those who develop LibreOffice install package for Win, not MS developers creating the OS service).

Yes, I did mean excellent open-source developers like your good self! I have edited my self-solution to show that my problem is not widespread, at least I can’t yet identify what changed my folder permissions and it might be a rare security “fix”. I can only guess that perhaps the MSI could check for permissions it will need before getting so far?
BTW can you suggest documentation of what folder permissions and inheritances there ought to be in a standard Win10-1803 installation?

it might be a rare security “fix”

Might be. There are some tools for “hardening” this and that… and they might be useful actually, I don’t say they are all crap.

perhaps the MSI could check for permissions it will need before getting so far?

Well - we try to use as few non-standard MSI actions as possible. Such a check needs to be non-standard, and I’m sure that it would bring much more failures than avoided problems. Each non-standard action does :slight_smile: - I say from experience.

Of course, I understand one’s frustration when stumbling across such a problem. But see: tens of millions of installs generate - let’s say - hundreds of error reports. That constitutes less than 0.01%. If we introduce a check without taking into account all possible situations, we will (1) need to support the additional code (man-work); and (2) deal with unforeseen consequences.

I assure you that resources like this (with questions+resolutions) deal with this much better.

When some reports start getting frequent, we see that a problem becomes more important. And we try to improve then.

can you suggest documentation of what folder permissions and inheritances there ought to be in a standard Win10-1803 installation?

No - I don’t know of such. But I can tell you which settings are on my test system if you need.

Brilliant response!
I have looked before for a good Win32 utility for mass permissions control (ACL) with not much success. There are very good apps for Linux using ntfs-3g and perl but of course they wouldn’t easily port to Windoze. I have a dual-boot system and several USB boots with different distributions so I can sort it. What would you use to just list yours, as you offered? (Don’t waste any more of your time - I’m retired!)