Installation results in Errors 1335 "The cabinet file '' required for this installation is corrupt and cannot be used" and 2350

When installing 3.5.4 on my Windows 8 Preview Release system I get the following message:

Error 1335. The cabinet file ‘’ required for this installation is corrupt and cannot be used. …’

Selecting the ‘Ignore’ option results in an error message 2350 and the installation ‘rolls back’.

Are you able to help please?

Hi @etsac, Please file a bug about this problem! The QA team will be happy to help you track down this bug! Thanks!

same problem installing on win7. was working but now an odt file has no program linked to it & attempting to re install results in same problem. my now absent son set up a bit torrent sequence which i previously used to download. have no clue what a mirror site or checksum is. how can this problem remain after 17 months. will try bugzilla next.

Solved. I got the same error 1st time. I suspected google chrome corrupting the download files and used mozilla to download (since it does not have any word processing software. hopefully, it wont do such a thing). It installed without any erros.

FYI…At least on win7 / vista, there is this problem that can occur when installing software. its pretty detailed but seems to settle around some lack of specific credentials to the file. The errors center on Hresult = 0x8007371B

MS does not seem to interested in addressing. It appears the fix is to go into registry and change some settings.

Dont know if that has anything to do with your problem…but did give me a hard time on various legit pieces of software I tried to install in win7 machine.

I am having exactly the same problem with Windows 7 Starter.

It won’t let me download the version that comes from bittorrent, either.

Same problem. Corrupt cabinet file. Trying to install on newly purchased Dell laptop w Win 7. Nothing seems to work - multiple attempts at downloading Libreoffice.

There are a number of related questions on the site. Most of them seem to point towards a corrupted installer file or archive:

The general fix is to

  1. Download the files again (if you get the error twice, try another download mirror)
  2. Confirm the checksum of the files

same problem on newly purchased vaio ultranote w Win 8.

I’m facing the same problem but on an old HP Windows XP machine. Several previous versions of LO installed just fine, but I ran into this 1335 error when trying to upgrade to 4.2. It doesn’t seem to matter where I download it from, I keep getting the same error message. More frustratingly, I can’t reinstall the LO version 3.6.7 that I apparently still have on my hard drive, because now I get the same 1335 error message for that one too! Help!

Finally was able to download a good copy of version 4.1. I tried several mirror sites that kept giving me the same error message, but then I sat down with a map and tediously figured out which mirror site was closest to me; then I downloaded it again with the speed throttled down and finally got a clean copy that installed properly. I don’t know if a defective package got distributed to multiple mirror sites, or if, as some here have speculated, there’s a particular “fragile” file within the package that is vulnerable to corruption at high download speeds. But since I’m not the only person experiencing this problem, LibreOffice needs to look into it.

Same error trying to upgrade to 4_3_4. on Windows 7. I get the file corrupt message and when I retry or ignore I get an internal error #2350 and the whole thing aborts. The failed upgrade also seems to have removed my old version of LibreOffice but I kept a copy of 4_3_0_4 and was able to re-install that successfully phew… seems others were not so lucky. I hope this can get addressed at some point, it would be nice to have the most current version.