Installation Sprachpaket: "Dies ist keine gültige Installation von LibreOffice 7.1"

Bei Installation des deutschen Sprachpakets zu LibreOffice 7.1 bricht die Installation mit folgendem Fehler ab:

Dies ist keine gültige Installation von LibreOffice 7.1

Offenbar existiert der Bug immer noch. Mir gelingt es nicht, die Version 7.3.4 mit dem deutschen Sprachpaket zu versehen. Ich bekomme exakt dieselbe Fehlermeldung wie hier angegeben. Bei einer der vorhergehenden Versionen ist es mir mit Löschen und Neuinstallation gelungen. Aber ich dazu habe ich keine Lust mehr. Das sollte doch wohl einfacher gehen. Ich kann nicht verstehen, dass der Bug so lange weiterbesteht, wenn man offensichtlich die Lösung kennt.
Für Hinweise zur einfachen Lösung bin ich dankbar.
Es grüßt
bhh

Inzwischen habe ich eine Lösung gefunden. Der User tebe hat es im März 20 beschrieben: Profile - tebe - Ask LibreOffice
Bei mir hat der Workaround funktioniert. Man muss nur bedenken, den Inhalt des Sprachpaketes in ein Verzeichnis zu kopieren, auf dem man Schreibrechte hat. Dann die beschriebene Änderung vornehmen und das Script im Scripteditor ausführen. Bei mir hat das gut geklappt. Dem User tebe sei Dank für die Beschreibung.
Es grüßt
bhh

Hallo,

das ist Bug tdf#134607 - LO7RC1 - LANGPACK macOS - many versions fail to recognize LibreOffice 7.0 / 7.1 installation as valid on Catalina and Big Sur - leider.

Die unten in Englisch gegebene Antwort ist zwar inhaltlich korrekt aber

  • ohne genaue Beschreibung, welche Datei geändert werden muss ( btw /Volumes/LibreOffice de Language Pack/LibreOffice Language Pack.app/Contents/osx_install.applescript, wenn man das Installationspaket mit dem Diskmounter eingehängt hat), wie man an diese Datei dran kommt und insbesondere, wie man die durchgeführten Änderungen auch sichert (Das Installationsvolume wird mit Nur-Lese Berechtigung eingehängt) ist das relativ schwierig zu bewerkstelligen.

  • ist das einem normalen Anwender nicht zuzumuten (und so etwas sage ich eher sehr selten).

1 Like

Sorry, bin’s überhaupt nicht gewohnt, auf deutschen Foren unterwegs zu sein, daher ist Englisch bei mir ein Automatismus. Und ja, vermutlich falsches Forum, das ist nix für einen Normalanwender. Habe lediglich für mich untersucht, woran es liegt und die Info an (wenn auch nur einigermaßen) passender Stelle loswerden. Wer weiss, wo sie hin gehört, kann sie ja dort gerne reposten.

Der Bug tritt auf, wenn im Finder die Option “Alle Dateinamensuffixe einblenden” aktiviert ist.

Meine Meinung dazu: Als Analyse sehr gut, als Workaround ist die dazu angegebene Lösung in Ordnung und hilfreich, aber einem Installationsskript muss diese Einstellung herzlich egal sein.


Für mich habe ich das Skript so angepasst, dass es das tut was es soll, funktioniert aber auch nur dann, wenn ich speziell noch `set sourcedir to "/Volumes/LibreOffice de Language Pack/LibreOffice Language Pack.app/Contents"` hart kodiere, weil das Skript im Read-Only Verzeichnis nicht geändert werden kann, daher woanders hin kopiert werden muss, aber die Orginalversion das `sourcedir` bzgl. des Pfades zu seinem eigenen Speicherort bestimmt. Insofern auch nur funktional für genau dieses `de` Sprachpaket. (**PS** Ein `rw` remount des `.dmg` files ist mir nicht gelungen - und **alles** woanders hin kopieren wollte ich nicht; sollte aber dann ohne diese Änderung gehen)

Ja, das kann der Programmierer des Installationsskripts wie folgt hinbekommen:

tell application "Finder"

	if (all name extensions showing of Finder preferences) is true then
		set displayedName to "LibreOffice.app"
	else
		set displayedName to "LibreOffice"
	end if
end tell

und dann die Variable entsprechend einsetzen.

Danke!

:heavy_check_mark: Das hat geholfen.

Nachtrag: Wenn ich es richtig verstanden haben wurde das nun durch die Verwendung von kMDItemDisplayNameWithExtensions (anstelle von kMDItemDisplayName) gefixed.

@msmr

Wenn es Dir geholfen hat, wäre es nett, das durch Anklicken des kleinen Häkchens (:heavy_check_mark:) direkt neben der Antwort (wird grün dabei) kenntlich zu machen. Vielen Dank …

Ja, die Lösung mit kMDItemDisplayNameWithExtensions (kannte die Option nicht) ist sicher weit sinnvoller.

Sorry für den versehentlich englischen Post:

Hier gibt’s ne bessere Antwort:

https://bugs.documentfoundation.org/show_bug.cgi?id=134607

Good news everyone, seems that Florian just stumbled upon what is causing the issues:

  • the bug occurs if you configure finder to show all file extensions

[…]

Finder | Properties | Advanced → first option there…

Auf Deutsch:

Gute Nachricht für alle: sieht so aus als sei Florian über die Ursache gestolpert:

  • Der Bug tritt auf, wenn im Finder die Option “Alle Dateinamensuffixe einblenden” aktiviert ist.

Also: Finder → Einstellungen… –> Erweitert → dort die Option rausnehmen, installieren und bei Bedarf wieder reinnehmen.

Allerdings könnte ich mir sehr gut vorstellen, dass unterschiedliche Versionen von AppleScript (je nach OS Version) unterschiedliche Ergebnisse erbringen könnten. Apple hat in seine unendlichen Weisheit solche Dinge über die Jahre immer wieder geändert / verschlimmbessert.

Meine ursprüngliche Antwort

The installation AppleScript for the package has two longstanding bugs, at least speaking of System 10.13.6, High Sierra:

(1) the following line is flawed:

set found_ooos_all to (do shell script “mdfind “kMDItemContentType == ‘com.apple.application-bundle’ && kMDItemDisplayName == ‘LibreOffice’””)

it has to be

set found_ooos_all to (do shell script “mdfind “kMDItemContentType == ‘com.apple.application-bundle’ && kMDItemDisplayName == ‘LibreOffice.app’””)

to work.

(2) Similarly the following line

do shell script “mdls --raw --name kMDItemDisplayName --name kMDItemVersion " & quoted form of (choice as string) & " | xargs -0 | fgrep ‘LibreOffice 7.1’”

must read

do shell script “mdls --raw --name kMDItemDisplayName --name kMDItemVersion " & quoted form of (choice as string) & " | xargs -0 | fgrep ‘LibreOffice.app 7.1’”

to make the installation process work.

Hallo,
ich hab’ mir gerade die 7.2.2 installiert und bekomme die gleiche Fehlermeldung (natürlich entsprechend “…7.2”); egal ob mit oder ohne Anzeige der Suffixe im Finder (macOS Mojave 10.14.6)

Hat jemand ne Idee?

Kann man das Language Pack nicht manuell irgendwo reinpatchen?

OK, ich hab’s auf eine etwas “unorthodoxe Art” selbst gelöst:

Ich hab’ LibreOffice danach sowieso auch auf meinem anderen Mac (BigSur 11.6.1 intel) 7.2.2 updated, und dort hat das Language Pack funktioniert. Also die App gezippt und auf den Mojave Mac gezogen, dort entpackt - et voilà :innocent:

Bei mir ist die Installation des deutschen Sprachpaket zur Version 7.2.5 fehlgeschlagen (macOS 11.6.2).
Nachdem der hier beschriebene Workaround nicht funktioniert hat, habe ich mir das Installationsskript mal genauer angeschaut und festgestellt, dass dort mit Hilfe der Spotlight-Datenbank die aktuell installierte LibreOffice-Version gesucht wird.

Ich hatte mal aus Gründen das Programme- (Applications) Verzeichnis von der Spotlight-Indizierung ausgenommen (Einstellungen → Spotlight → Datenschutz). Nachdem ich das rückgängig gemacht hatte und eine Weile auf die Aktualisierung der Spotlight-Suche gewartet hatte, funktioniert auch die Installation des Sprachpakets problemlos.

Also falls bei Euch aktuell die Installation des Sprachpakets nicht funktioniert, sucht mal mit Spotlight nach “LibreOffice”:
Es sollte die installierte LibreOffice.app finden; falls nicht könnte das auch bei Euch die Ursache sein.