Installing language pack in LibreOffice Writer Linux (Ubuntu 15.04)

I tried to install the language pack in LibreOffice, because I would like to have a Swedish spell-checker. I did as follows:

  1. Downloaded the language the extension from
  2. Tools->Extension Manager->Add and marked the file followed by Open.
  3. After a while got an error message indicating Java was missing, checked that and it was true.
  4. Installed Java runtime according to: which went well.
  5. Repeated the installation from step 2 and now this error message appeared: { { Message = “[jni_uno bridge error] UNO calling Java method writeRegistryInfo: non-UNO exception occurred: java.lang.NoClassDefFoundError: com/sun/star/task/XJobExecutor\X000ajava stack trace:\X000ajava.lang.NoClassDefFoundError: com/sun/star/task/XJobExecutor\X000a\X0009at java.lang.ClassLoader.defineClass1(Native Method)\X000a\X0009at java.lang.ClassLoader.defineClass(\X000a\X0009at\X000a\X0009at\X000a\X0009at$100(\X000a\X0009at$\X000a\X0009at$\X000a\X0009at Method)\X000a\X0009at\X000a\X0009at java.lang.ClassLoader.loadClass(\X000a\X0009at java.lang.ClassLoader.loadClass(\X000a\X0009at\X000a\X0009at java.lang.ClassLoader.loadClass(\X000a\X0009at\X000a\X0009at\X000aCaused by: java.lang.ClassNotFoundException:\X000a\X0009at$\X000a\X0009at$\X000a\X0009at Method)\X000a\X0009at\X000a\X0009at java.lang.ClassLoader.loadClass(\X000a\X0009at java.lang.ClassLoader.loadClass(\X000a\X0009… 15 more\X000a”, Context = ( @0 } }*

Do you gave an suggestions how to resolve this problem? My skills Linux are very limited, I am in the beginning of the learning curve.


[Edit: added LO + Ubuntu tags]

Hi Göran

Don’t you hate it when Linux starts acting like Windows™?

First try the all-encompassing (and simple, easy + reversible) fix of:

Resetting the user profile:-

“If you notice any strange behavior on LibreOffice, or simply it fails to start, the first thing to try is to reset the user profile.”

  1. Shutdown LO/OO + Quickstarter
  1. Find your user-profile directory
    (enable ‘Show hidden files’)
    (note: 5.x profile location is identical to 4.x)
  2. Rename it
  3. Restart LO/OO

…and try again.

LO/OO is very prone to Profile Corruption. In the absence of an existing profile it is designed to re-create a new profile, and that neatly fixes many, many problems.

Here’s some further (possible) help:

There are lots of reports of LO-4.4 having issues with Java, including Q45627 + Bug1213130 (other bugs are also available).

The following comes from the last two links:-

“On Ubuntu, after installing libreoffice-java-common package all works fine”

(the above from Repository; use the following if you want to (re)install LO from Repo):

This additionally comes from Q45627 + first link:-

"SOLVED by uninstalling libreoffice (apt remove libreoffice-* ) and then installing the latest version from the repositories. funnily I think this is the same version I had (4.4.0), but now it is working."

If this helps then please tick the answer (:heavy_check_mark:)

Hi and thanks for the reply!
However, I am a beginner in Linux and as such I don’t have a clue how to execute your instructions, so more details would be appreciated.
Do I have to remove the Java runtime, if so is: apt-remove java- the command to use?

I have finally solved the problem, as follows:

  1. Removed the previous Java and LibreOffice ( installations.
  2. Installed Java and LibreOffice 5.0 in the mentioned order.
  3. Installed the Swedish spell-checker.
  4. Everything went fine!