Invisible text when exporting PDF with Acumin Variable Concept font

When I export a PDF from Writer, any text using the font “Acumin Variable Concept” does not show up in most (but not all) viewing software I’ve tried. Document Viewer v3.36.10 (default in Ubuntu 20.04), Android’s default PDF viewer, and Microsoft Edge all fail to show the text. Inkscape does show the text, with some formatting errors.

Images, text sections with other fonts, etc. are all exported correctly and I believe the document structure is correct; but any text in the font I’m using aren’t rendered visibly.

The symptoms sound identical to those described in this question, except my problem appears to be font-specfic: Text not showing when exporting to PDF or printing in

I’ve tried purging and re-installing, as described in the answer to the above question, and the problem remains. I’m able to export the same document successfully in Abiword (text is visible and the correct font is used; Abiword screws up the formatting in unrelated ways and is not a suitable workaround).

The font is properly embedded according to pdffonts.

I speculate that perhaps this issue is related to using a variable font, but I don’t have any other variable fonts to test with.

I think bug tdf#108497 applies, see comment 11:

We currently do not support variable fonts at all, any apparent support is accidental

Gravity font might be a suitable substitute. CC4 by Vincenzo Vuono

I believe that explains my problem … thanks for pointing it out.

I guess the solution is wait. I do wonder if things have progressed since 2018 though?