Is spell check in Version implemented?

In trying to get the default language set for all new writer documents, I have discovered that I can’t get spell check to work in LO (which I just installed yesterday). How do I get my default language set to American English for all new writer docs, and get the English dictionary installed please? (This is on a Windows 10 laptop)

Hi Al Vesper

It’s a setup issue, usually.

In brief, you need to:-

  1. Get your OS locale set correctly
  1. Download a LO which is the same locale as your OS
  2. Download a spell-dictionary (extension) with the language that you work in (often the same as your locale)
  3. Double-check the setup


  • Locale:
    Windows tells you that this only affects non-Unicode programs. They are talking nonsense.
  • LO Downloads (Still or Fresh):
    Each page attempts to guess your locale & OS from your Browser. There are also links to allow you choose a specific UI-language and/or OS (in case it gets it wrong).
  • Spell Downloads (EN)
    Loaded from within LO once downloaded:
    (menu):ToolsExtension Manager...Add...
    image description
  • Check Setup
    First, check general setup:

    (menu):ToolsOptions...Language SettingsLanguages

    UI+ Locale should ordinarily both be the same as your OS-locale.
    Set Default Languages for Documents
    (the ABC + blue :heavy_check_mark: means that it is also available as a spell-check language)

    Now set default spell-check language:
    (3 options): 1) For Selection 2) For Paragraph 3) For all Text
    image description

You should now be good to go.

If this helps then please tick the answer (:heavy_check_mark:)

…and/or show you like it with an uptick ()

Why does the text language say none and the spelling icon in the tool bar is gone?