[Writer] No UK-English spell check after updating to 5.0.3

I updated LO from 4.x to latest 5.0.3 in Fedora (Linux) and spell checking no longer worked. To make sure, I typed typos which were not highlighted with the traditional wavy underline. Tools->Auto correction is checked, general language parameters are set to spell check while typing, dictionaries are loaded and available.

Since I work on a multi-lingual document (en_UK, en_US for licence/license statements and none for computer language examples), styles explicitly state the language used for text. The UI and default document languages are different from those in this document but this should not matter.

Until the update, this worked like a charm. If I force a manual spell check (F7), I only get verification of the license appendix written in en_US. My main text in en_UK passes the verification despite the voluntary typos.

I read this question, but it does not seem to solve my problem. I think my configuration is correct (but I may be wrong). Others questions in ask.libreoffice.org seem to indicate that spell check is non-functional in 5.0.

How can I restore spell checking?


I re-checked Tools->Options->Language Settings more thoroughly. I clicked the Edit button after selecting Hunspell Spellchecker. I then used the drop-down menu to choose the language and set options. There is an A aside en_US and Hunspell is checked. But, although I reloaded the most recent English dictionary (supposed to include _US, _UK, _AU and others), there is no A aside en_UK and when selected, no Hunspell check box in the options.

Does anyone know of a configuration issue in the English dictionary?

Hi ajlittoz

Look at my answer in Q59898 (5.0.0 UK). Go through all the steps carefully.

(Added after a lengthy exchange via comments):

Unless the person using LO uses en-us (USA spell-checker) it will be necessary to install a User-Interface Language Pack for your language in addition to the standard LO package (the LangPack is ~30MB as opposed to 100’s MB for the LO install). After install, the language also needs setup as detailed in the earlier links.

For myself (LO-5.0.0 under Debian) this UK language-pack file was called LibreOffice_5.0.0_Linux_x86_deb_langpack_en-GB.tar.gz.

It may well seem complex, but if you factor in the ability to have different languages for the locale, UI & text it’s not too surprising.

If all else fails reset to a default Profile (Q59016) (non-destructive + easily reversible). That solves so many LO problems that it really is silly.

If this helps then please tick the answer (:heavy_check_mark:)

…and/or show you like it with an uptick ()

First thing first, lot of thanks for answering fast. Here is what I did:

A- Reset my profile, reenter my document, no change

B- Check everything according to Q59898.

B1- In Tools->Options->Language settings, dictionaries for French and variants are A-marked with check, but only en_US is available (no en_UK or others)

B2- Went on a typo in my text, there Tools->Language->Selection with en_UK checked as expected but ->Paragraph or ->Document show no ticks

Where should I head now?

I downgraded to 3.x to compare settings. B2 in previous comment exhibits same tick on Language->Selection and no ticks on Language->Paragraph and ->Document but checkspelling is OK

The difference is in B1 Tools->Language Settings->Languages where “Default language for document” allows to select many English variants, which I can’t do in 5.0 (no abc+tick aside English variants apart from en_US).

My guess is something went awry in recent updates of English dictionary.

Hi @ajlittoz

When you updated to 5.0.3, did you update the spellcheck extension for en-gb as well? Mine for 5.0.0 was called LibreOffice_5.0.0_Linux_x86_deb_langpack_en-GB.tar.gz (it is a language pack–which, I believe–includes grammar-check as well as spell-check, and whilst the main LO download may have an en-gb UI it will NOT have an en-gb language-pack unless you download & install it). Then, after install is setup.

Hi Alex,

I upgraded the usual manner (for me) through the Fedora package manager: I filtered on libreoffice keyword and loaded my “standard” collection. In Fedora concept, the spellcheck extension is included by default in the base package (or at least it seems so since I never downloaded it explicitly). There are also packages libreoffice-langpack-xx containing translations (UI) and ressources. I had a look on the 3.x one but filenames are cryptic and I can’t identify the dictionary.

As I wrote in a previous comment, the main difference between 3.x and 5.0 is in the list of available language varians in Tools->Languages Settings->Languages. In 3.x, I can select en_US, en_UK, en_xx: they all have abc+tick. In 5.0, only en_US has abc+tick. This is why I put the blame on the dictionary. Earlier this morning, I manually installed the latest en dictionary through Extensions Manager but it did not change behaviour. Only en_US is selectable.

@ajlittoz: put the names into a pastebin and we’ll help. I don’t have practical experience with Fedora packages apart from seeing some of them as an outsiders, but I’m not the worst to understand package names; and although my googling skills could use improving I should be able to dig up what the package means; otherwise, just open the file.

Hi @ajlittoz

I’ve had to re-learn all over again from scratch where on earth I downloaded the ‘…deb_langpack_en-GB…’ from. It turns out that it is a “Translated User Interface” and was downloaded, therefore, from exactly the same place that the original LO-5 was downloaded. The point here is that standard LO is always in EN-US, and therefore so is the spell-checker. langpack size is ~30MB.

Hi @ajlittoz

Re: fedora. I spent 10 years as network admin under RHEL + CentOS. You use RPM under Fedora just like RHEL. EN-GB Lang-Pack will be packaged separate from main LO rpm. LO-Fresh includes RPM downloads in addition to DEB downloads. Check current installed LO packages with yum. You need en-gb langpack.

Hi Alex,

You’re some kind of magician. I am ashamed because I should have checked that first before bothering the world.

I downloaded libreoffice-langpack-en. Dependencies brought in hunspell-en (though I had some "reduced?"English version installed), mythes-en (thesaurus) and most important hunspell-en-GB. I don’t know how I could have forgotten those were needed.

Once again, my apologies.

I’ll write an answer with the right solution for the records. Thanks for your help.

Hi again @ajlittoz

You do not need to “write an answer with the right solution” - that is what my answer + these comments are.

Do not forget to select/mark my answer as the right one.

Adding to what Alex says. With my Linux-Mint-Mate 17. I have 4.3.4 and sharing the same .config/libreoffice configuration folder and 5.1 with its own folder. I have a document in three parts, English(GB), American(USA) and French(French). I have also tested English(Australian) and French(Switzerland) with the 5.1 version. They all work as expected. However, I installed the LibO directly not using the distribution copy.

As the 4.xx and 5.0xx versions use the same profiles, I wonder if something went wrong during your updates?..Peter

The profile sharing could explain why I also have now problems attempting to open the document from LO 4.x. Both 4.x and 5.0.3 enter document recovery on startup but do not complete recovery.

Thanks to Alex Kemp, the issue is solved. Here is the explanation (at least for Fedora Linux distribution).

Basic packages for LO only contain US-English language material.

Whenever you add another language through a “langpack” package (under Fedora, they are named libreoffice-langpack-xx), this master package also installs the spelling checker and dictionaries needed for the language and its variants.

In the case of English, though LO is already fully functional after its fresh install, installing the English language pack is mandatory to activate the numerous variants (en_UK, en_AU, en_ZA, en_CA, …) and load the appropriate spelling checker and dictionaries.

To use “international” English, needed packages are: libreoffice-langpack-en which requires hunspell-en, hunspell-en-GB and mythes-en. Adapt package names for other distributions.