Is there an UK English dictionary which does not also include US English spelling?

I cannot get a UK English spellchecker which does not also include US English spelling. This was not a problem with LibreOffice 3 as the standard English UK spellchecker worked perfectly but this is not the case with LibreOffice 4.

Is it possible to replace the dictionary in LibreOffice 4 with the one in LibreOffice 3? If so, where is the spellchecker dictionary located in LibreOffice 3 (using Ubuntu [Zorin 5]) so I can, perhaps, copy it or could you make it available on line so that I can download it?

I’m now using Mint 15 and the and LibreOffice Version:, Build ID: 1c1366bba2ba2b554cd2ca4d87c06da81c05d24

Simple examples: neighbor; labor, center, color are not picked up as incorrect although, of course, they are incorrect in a UK English dictionary.

Thank you in anticipation of your attention.


It sounds as though either the en-GB language pack is not installed or the text in the document is not set to be en-GB. EDIT: Please refer the checklist provided in this answer.

There is certainly no problem with the en_GB or en_US dictionaries as a quick grep verifies:

$ grep -e labor /opt/libreoffice4.1/share/extensions/dict-en/en_GB.dic 
collaborate/6	1
collaboration/2	1
collaborationist/2	1
collaborative/42	1
collaborator/2	1
elaborate/88	1
elaboration/2	1
elaborative	1
laboratory/13	1
laborious/14	1
$ grep -e labor /opt/libreoffice4.1/share/extensions/dict-en/en_US.dic 
belabor/11	1
collaborate/6	1
collaboration/1	1
collaborationist	1
collaborative/8	1
collaborator/1	1
elaborate/67	1
elaboration/1	1
labor/23	1
laboratory/15	1
labored	1
laborer/1	1
laboring	1
laborious/16	1
$ grep -e color /opt/libreoffice4.1/share/extensions/dict-en/en_GB.dic 
coloration/2	1
coloratura/2	1
colorimeter/2	1
colorimetry	1
$ grep -e color /opt/libreoffice4.1/share/extensions/dict-en/en_US.dic 
color/23	1
colorant/1	1
coloration/2	1
coloratura/1	1
colored/1	1
colorfast/33	1
colorful/16	1
coloring/1	1
colorist/10	1
colorization/2	1
colorize/6	1
colorless/16	1
color	1
colorway/10	1
discolor/11	1
discoloration/1	1
multicolor	1
recolor/11	1
technicolor	1
Technicolor	1
tricolor/1	1
uncolored	1
watercolor/18	1

Thanks very much for your help but now I may need your further assistance as I’m not the most adept computer expert. My grep is the same as yours and the en-gb.dic is fine when I look at its various spellings. In my language options I have default language English-UK so can’t have loaded the language pack correctly. Further advice would be most welcome - particularly how to rectify my incompetence!

For Mint (.deb package), v4.1.5.3, x86_64 architecture, you will need to download the en_GB language pack, unzip it, and install it ($ sudo dpkg -i *.deb). The x86 version is here.

Still not working OK. The En-GB dictionary is located in my file system at /opt/libreoffice4.1/share/extensions/dict-en/en_GB.dic but no matter what I click in LibreOffice Tools Options Languages or Writing Aids I can’t get it to function. As a matter of interest under “Default Languages for Documents” I have ABCtick Default English (UK) but loads of other languages with ABCtick beside them. Could deleting all the others en-??.dic from /opt/libreoffice4.1/share/extensions/dict-en/ be the cure?

FWIW - I’m on Mint (13 LTS) but LibO it’s working fine for me. Here’s a screenshot of my language options for comparison. I also have other languages (which I have “installed”) as possible “Default languages for documents”, but the main default is “English (UK)”. When you do your spell check (F7), what language is showing at the top of the dialog that opens? and which “Text language” in the drop-down at its top?

Thanks for your help David and oweng.

David, My Option - Language Settings-Language is identical to yours apart from the fact I do not have Hebrew and my date preference is DMY. When I press F7 I get "Spelling and Grammar: English (UK) and the text language in the drop down at the top is English (UK)!! I’m mystified. Should I just update to the latest version and hope for the best?

What does it state in the status bar for the document in question? I presume the “English (UK)” entry in the languages selection has the blue tick next to it? If this is all as expected, then I am unclear why the spell-checker is not working as expected. Perhaps try a user profile reset and if that is unsuccessful, try un/re-installing.

Thanks again oweng,

Status bar shows English (UK). When I open “Option - Language Settings-Language-Default languages for documents” all English language options have a blue tick next to them as do all French and Spanish for some reason. The only difference is that it starts with “Default - English (UK)”. I might have a go at installing the latest version - would it be wisest to delete the existing one first?

@BazP, I always delete a prior install. Migration of user-profile detail has been known to cause problems in the past. Be sure however to backup anything in your user profile that you want to keep (e.g., user-defined dictionaries).

I must be a complete dunderhead as I can’t get a dictionary working that doesn’t permit EN-US words…it’s like a plot!! Today I’ve not only reloaded LibreOffice in the hope that my problem would resolve itself (Version (Build ID: 400m0(Build:2) but I’ve also reinstalled Mint, just in case. I must be either doing something wrong or not doing something I should be doing. I’m so mixed up now I don’t even know where to get a UK-EN Dictionary let alone load it.

@BazP, “Build ID: 400m0(Build:2)” this indicates you are using the Mint-supplied variant of LO from the Mint repositories. Perhaps try installing the website version as a test. This should at least indicate if it is a problem with the Mint-supplied variant.