JDBC Driver Cannot be Loaded Update

For some unknown reason my java connector between base and mariadb stopped working. In researching the issue, this post provided the roadmap to get my connection working again. The OP wrote: “After a lot of fiddling around I changed the connector to “mysql-connector-java-5.1.46-bin.jar”.”. Installed “mysql-connector-j-8.0.33.jar” and it worked.

Consequently I am left with two questions:

  • Why has the mariadb connector (mariadb-java-client-2.7.3.jar) all of a sudden failed?
  • It also appears that mariadb has changed the format of its jar files. Instead of something like “mariadb-java-client-2.7.3.jar” what is shown now is “mariadb-java-client-2.7.3-sources.jar”. I tried this “new” format, but it didn’t work either.

Using Libreoffice:
Using mariadb:Server version: 10.6.12-MariaDB-0ubuntu0.22.04.1
Using Linux Mint: 21.1

Any thoughts?

Have tested a little bit.
Downloaded different JDBC-drivers for MariaDB: Download JDBC-connectors MariaDB
You could get all JDBC-divers for MariaDB here: All JDBC-connectors for MariaDB
Current versions are
There are differences to the sources-files. Sources-files won’t work.

Connection with 2.7.9.jar will work here with OpenSuSE 15.4 64bit rpm Linux.
Connection with 3.1.3.jar will fail. You have to connect through JDBC by
Go to Edit → Database Properties → Advanced Properties and add ?permitMysqlScheme to the database name.

By the way: There is a direct connection available for connecting Base with MariaDB.

1 Like

Thanks for your response, it was very helpful. Especially from the context of identifying the correct location to download the MariaDB JDBC drivers. At one time I had the correct location, but evidently lost it.

"By the way: There is a direct connection available for connecting Base with MariaDB."
Yes, I have the direct connection working. Getting the JDBC driver working was an educational objective to learn more.

Unfortunately, I was unable to get mariadb-java-client-2.7.9.jar or mariadb-java-client-3.1.3.jar to work. The following JDBC does work: mysql-connector-j-8.0.33.jar. So from that perspective, this question is solved.

The image below is the error message received when attempting to use the MariaDB JDBC connectors. Incorrect driver class designation?


For MariaDB you will need


not com.mysql.jdbc.Driver or for newer MySQL driver com.mysql.cj.jdbc.Driver
Have a look here: Base Guide - English
Original is from older German Base Handbuch I wrote. All I have written above will be available also in German Base Handbuch 7.6.

1 Like