Justified Persian (Farsi) paragraphs!


My documents are in Persian (Farsi) language.
When I set the alignment of the paragraph relative to the “Justified”, inserts a dash line under some letters of word and a space between of that word!

How can I fix this issue?

image description

Thank you.

Show a sample file.

Which font are you using? Is text language set to Farsi? Have you enabled Complex text layout in Tools>Options, Language Settings>Languages?

As usual, quote your OS and LO version.

Please do not use Add Answer but edit your original question to enhance the details of your question (answers are reserved for solutions to a problem on this Q&A site).

Had a look at your file. The highlighted word is made of jeem+kasra reh meem

Do you expect kashida being used in justification instead of apparently space expansion?

Anyway, your text is plagued with direct formatting. There are so many layers of it, I don’t know how to get rid of which. At least I found text colour, justify alignment, font size, font face, highlight colour. There may be others.

If you expect predictable and repeatable results with Writer, use styles exclusively, all the more in sophisticated text. Your manual formatting is a big mess: Text Body paragraph style with which your text is styled says font IRMitra 16 pt. You manually patched this for IRANSans 18 pt.

It is impossible to give you advice unless you rework your formatting for styles since I can’t read Farsi. I can only analyse how it is formatted relative to recommended Writer practice.

I use IranSans font that is a standard Persian font.
Yes, I enabled CTL.
OS is Linux Mint 20.1 and LO
Sample File.odt

Do not answer your own question unless it is a real answer. Modify or comment the original one.

I’m not sure what you mean under a standard Persian font, but I have never heard about IRANSans (and I don’t have it). I tried several fonts available in my system and cannot see any issue with the highlighted word, which makes me think that the issue is about the font, not about LibreOffice.

I updated sample file with IRMitra Font and the issuse is there yet.

Also I uploaded IRMitra font in this link:


The problem is not primarily with fonts (whichever they are), but with the accumulation of direct formatting. As I am not literate in Farsi or any Arabic variant, I don’t know what I must look for. On my computer (Linux Fedora 33), your fonts are substituted for another one. All I can see is your highlighted word is made of jeem+kasra reh meem without any added dash. Do you mean you have an underline under the first letter? If I do that, a relatively thick line is drawn under the word well below the base line.

Please describe what is “abnormal” in your picture above. All I see is a faded half stroke ending at left of jeem. I can’t study various formatting options because of your direct formatting. I seem to be unable to get rid of justify alignment, other than clear direct formatting on the whole document. And even in this case, I see nothing unusual (but I don’t know what I should see).