Labels are repeated across page

I’ve created a mailing list database using instructions listed on this site (by registering the spreadsheet as a database, etc.). I’ve created my labels by using File -> New -> Labels but when I go to use the mail merge wizard, it generates whole pages of repeated labels for each address in the list. For example, John Smith’s address label is repeated over an entire page, then Jane Doe’s on a separate page, and so on. Ideally I’d get a label for John Smith, then a label for Jane Doe, and so on, and not entire sheets of labels for each.

Anyone have any idea as to what I am doing wrong?

EDITED to add details

OS: Kubuntu Linux 18.10
LO Version: 16.1

Steps I took (after creating a “holidaylabels” database in Base from the “holidaylabels” spreadsheet; the spreadsheet had 60 items in it):

  1. Opened Writer, went to File -> New -> Labels in order to generate a sheet of labels. I selected the “holidaylabels” database, added the fields to the template, selected a label format, then under the Options tab I made sure “Synchronize Contents” was selected.
  2. At this point I had a blank sheet with properly formatted labels with all the fields highlighted. I went to Tools -> Mail Merge Wizard.
  3. In the Mail Merge wizard, I clicked on “Next” on the first screen, then “Finish” because I knew I did not need all of the options.
  4. Then when I clicked on “Edit Individual Documents”, it generated sixty pages, each with a full sheet of labels for each address in my database.

I confirmed that my spreadsheet has sixty rows of data (61, including the column headings row). I also confirmed that the database table has sixty records in it.

I got my instructions from:

How Do I Create Labels from a Spreadsheet

as well as the LO documentation which I downloaded.

Hope that clears things up!

Hello,
I found your post looking for answers to the same issue (new to LO, using version 6.4 on a mac). In reading through the Writer Guide I happened upon some information that I think will solve the problem – it did for me! I won’t post under ‘Answers’ since I am new to the site and not sure this will solve the problem for everyone, but if it helps I thought it worth sharing. From Writer Guide Pg15, section 5.4 on Mail Merge (https://wiki.documentfoundation.org/images/6/68/WG5414-MailMerge.pdf):

"The last paragraph of the label address block ends with a special field,
Next record:Database.Table (Next record:Points.Sheet1 in our example) "

This field is ‘hidden’ in the standard label view for editing layout/font/etc before you print (it’s represented by a shaded space), until you activate View->Field Names from the menu. In modifying the layout, I have inadvertently deleted this field and it appears that is what causes the labels to print one record per page. Hope that helps!

Hello,

For label processing instructions you can use the LO documentation found here → LibreOffice Writer Guide. See Chapter 14 - Mail Merge.

You have not provided the steps you used or even a link to the directions you followed. You also have not provided the LO version you are using or your OS. But possibly this will help.

Once you have gone through the initial ‘Label’ dialog (where you select label format & fields) you select the New Document button. Once on this new document you can set any formatting you choose and apply to all labels provided Synchronize contents was set on the Other tab in the dialog (see documentation for more information).

Now the labels are ready for the next step. Select print. A message appears:

Your document contains address
database fields. Do you want to print
a form letter?

Select Yes. This presents the Mail Merge dialog where you select some or all records to print. Once selected the OK button will take you to actually printing the labels.

I edited my question to include the information you asked for. Sorry for the confusion.

Did you try my instructions or at least look at the pointed to documentation?

Just retested using your instructions. Cannot duplicate. Get individual records all on one page of labels. Must be more to what you have. Ran on Mint 18.3 with LO v6.1.4.2

Yes, I tried your instructions and read the documentation. Nothing helped.

Based on your comment and after having done this numerous times without this type of problem, I can only further suggest you first trying to run in Safe Mode. This is available under the Help menu as Restart in Safe Mode. A further description is found here → LibreOffice user profile.

If after this it is still is not working, file a bug report here → Bugzilla.

I have the same issue using version 6.3 and 7.0 when creating labels. I’ve even tried Safe Mode. But to be honest I don’t have any custom settings or configs setup. So as expected it did not help either.

I’ve inserted Next Fields in all the ways I know how. But in the end Libre-Office either prints one label per page or if synchronized prints a page of each record. Both options are wasteful if you only need one label of a heap records.

What I’ve done. I’ve read through all the forum posts I could get my hands on. I’ve read the official documentation - but this does not specify how to print one or several of each record.

I have the same problem. I am using LO 7.1.2.2. I have followed each step in Chapter 14, but when I use Mail Merge, select records 1-30, send the file to my printer, I get 59 sheets with the same address per one page. Mail Merge, select record 1-30, option - save as single document I get the same address in each label in a single page document. Mail Merge, select record1-30 option - save as individual documents, I get a single page with the same address in 30 documents. I get the same results in safe mode as well.

@lksweet54,

Just re-tested with LO v7.1.2.2 on Ubuntu 20.x and had no problem. When selecting print, it asks if you want to generate a form letter - answer Yes.

I answered yes and had the results posted above. I am running LO v7.1.2.2 on Windows 10.

@lksweet54,

File a bug report here → Bugzilla

Edit:

Just tested on Win 10 with LO v 7.1.2.2 and although it had a couple of blank pages (believe this is a setting) all other pages were filled with label data - over 60 labels generated (labels on only three pages total and the two blank pages - Five pages in total). No problem as you state.

@lksweet54,

Reviewing the comment under original question and deleting this last field, I was able to produce erroneous results but still not what you have described.

Safe Mode? I’m experiencing the same problem on Ubuntu Linux. There’s no such thing as Safe Mode in Linux.

The issue is whether each database entry populates a single label or all the labels on a page.
There’s a need for both:

When I’m making my return address labels, I want the same return address on every label. When I’m printing directly onto an envelope, I want one address per envelope.

When I’m making my outgoing address labels, I want only one label for each address, packing as many individual labels onto a sheet as are provided by the label maker.

Please only post as an answer when actually answering the original question. It should actually be posted as a comment or a new question (nothing in this posted question about envelopes).

Yes there is a Safe Mode. In the comment it states it is under the Help menu - this is for LibreOffice menu whether on Linux or other OS’es. There is also a link in the comment with further explanation on Safe Mode (User Profile).

I have the same problem. I am using LO 7.1.2.2. I have followed each step in Chapter 14, but when I use Mail Merge, select records 1-30, send the file to my printer, I get 59 sheets with the same address per one page. Mail Merge, select record 1-30, option - save as single document I get the same address in each label in a single page document. Mail Merge, select record1-30 option - save as individual documents, I get a single page with the same address in 30 documents. I get the same results in safe mode as well.

This started as just some quick observations… please don’t “shoot me” for lack of detail, even now… but…

I’ve been having exactly the same problem. LO with embedded Firebird on Win10. Experienced OPEN Office user… moving to LO.

(and apologies… (again- I did an edit, but it disappeared!) for putting this in the “Answers” section. Initially, that was a new-user-of-this-forum mistake. I tried to correct that, but found the information offered wouldn’t fit in a comment.) ANYWAY…

I’ve only ever used the Firebird embedded database with my Libre Office.

The “set” of “data” I’m dealing with is very, very basic. A crude, ad hoc table with some mailing addresses. All fields of type “text [var char]”.

I’m trying to have the system print the results of a query which filters which records are included, and sorts the records.


Ah… 90 minutes later…

I’ve done the “same thing” several times now… sometimes getting the RIGHT answer (one copy of each label, with many different labels on each sheet)… and sometimes again getting the SHEETS, each filled with multiple copies of one of labels I’m trying to print.

Sigh.

Can’t figure out what I do differently in the different cases… but the original poster is not alone. For the next people on this quest…

a) You don’t have to send the output to a file to save printing endless “bad” sets while struggling. The “ordinary”, “print to printer” process has a preview stage that is sufficient to see what the result of your latest experiment would be. Just “cancel”, after you’ve seen, and you can eat your cake (see what would happen) without having to eat it (use paper and ink.)

b) I’ve done a little bit of “re-arranging” of the positions of the fields on the labels after they are “dropped” there by the label spec process. That’s about the only “clever” thing I’ve done, and that doesn’t seem to be where the problem lies.

c) Not(?) related… but along the way, I’ve learned that if you want to put more than about 3(!) fields on the label, you can skip doing it via the tedious mechanism present in the “start a sheet of labels” wizard. Put at least one field on the spec during the wizard. Then, once the thing is up on your screen, while in design mode, use Insert/Fields/More Fields, and that will take you to a better place.

d) Seeming at random(!) a dialog pops up saying “The document contains embedded HSQL data, which is deprecated. Would you like to migrate to Firebird now?” That puzzles me, as I don’t believe I’ve used HSQL at any point in this exercise. I usually say “later”, as the few times I’ve tried “migrate” (here) either I got nowhere, or ran into some wall or other. (I may have misread the screen, but I’m pretty sure that when I created the new database (3 hours ago) I specifically noticed confirmation that the embedded Firebird would be used. I’m sure I never explicitly requested password protection for it, which has a bearing on my next observation…

e) From time to time, another dialog pops up: "Authentication required- wrong user name and password for [name of… my Firebird installation?]. I didn’t knowingly do anything to protect this set of data and queries, etc, but a password I had written down from other LO/Firebird work seems to make the authenticator happy. Sigh.

I hope someone can spot the “secret”!! If others are having the problem, but have “nothing to contribute”, just a “me too” would sill be helpful in encouraging the experts NOT to write this off as “silly newbies… they probably didn’t (language removed by @Ratslinger)”. That attitude IS often warranted. I’m beginning to suspect it isn’t the case here.

Abbreviated or not, Please refrain from unacceptable language.

You dialogs are not unusual. When accessing the data sources the system is getting all registered Base files. This could involve some with HSQLDB and if Enable experimental features is on (or an older version of LO) a conversion message pops up. This as well for other registered databases requiring a log in.

Have had the same issue for some time. Have tried with Mac OS Mojave and Big Sur with LibreOffice 7.1.5.2 and 7.2.0.4. Duplicate labels on each sheet - so 20 labels gives me 20 sheets instead of 20 individual labels.
Followed the Mail Merge instructions precisely from the documentation. Unfortunately I haven’t been able to work out when this feature got broken.