Libre Office 7 slow to open on fast windows 10 PC

Answering my own question. I’ve had problems with LO being VERY slow to open.
It opened fine in safe mode, but when started normally I got a splash screen, then a period of 20 - 40 seconds when it stalled, and was not even showing in task manager.

Finally it opened with thumbnails of recent files. I tried deleting some that were no longer valid - and it crashed.

I didnt want to delete my user profile as there are settings that suit the way I work.

I changed the file history size from the default down to 8 following instructions here (its hardly obvious!)

Now it opens almost instantly.

Please could you look if some files not in the history now, is not accessible. To test if it could be the source of the issue.

good idea, but I cant because the extended file history has been deleted. However I noticed there WERE files that were inaccessible. Trying to remove them from the history caused the crash.

BTW, I think something was done lately about that. Do you have an updated version?

So if you have this problem, try changing your file history size. Maybe one of the old files was causing issues, I dont know, but reducing file history did the job.

Please use the tool add a comment for any post not being an answer to the original question.

For LibreOffice 7 on Windows 10 try:

Tools → Options → LibreOffice → View → Graphics Output

and disable “Use anti-aliasing”.

that´s it.

Long Live LibreOffice.