Libre Office Dictionaries Path Cannot Be Changed

I’m trying to change the default Writer dictionaries path, to allow them to be shared more easily with other computers.

The process at first appears to work -
Tools > Options > Paths > Dictionaries > Edit > Add > Select Path > Click on radio button > OK.

If I double-check the settings immediately, the original and the new path are listed correctly. However after closing Writer and re-starting, the alternate dictionary path is missing.

I’ve tried changing all the other paths and they DO work ok - it’s just the Dictionaries path that refuses to change.

Anyone else experiencing this or am I missing something?
Using LO on Win 7.

Just encountered the same problem here on LibreOffice on Linux Mint 18.2. Did you file a bug report or manage to resolve this issue otherwise?

I would try to use LibO 4.3.6 or 4.4.1 and see if the problem persists.

Alas, I’ve tried the portable versions of LO 4.3.6 and 4.4.1 and they also exhibit the problem that an alternative Dictionary path won’t stick - tested on Win 7 and XP. Perhaps I should raise as a bug?