Libre Office slow to load Calc and Writer

Hello folks, just downloaded and started to use Libre Office with a view to moving onto Linux (currently on Win 10 Pro) a bit later on.

Functionality is fine along with layout and features, however both Calc and write load with a noticeable lag compared to Excel or Word, these are empty test documents in both native Libre Office format or Microsoft - both are the same.

Having used Libre Office before on Linux I don’t remember experiencing this lag, read a few help posts on this forum about safe mode but this is a fresh install/new documents.

The problem with Writer is it seems to have problems rendering the page, switched to basic single line menu instead of tabbed which did improve it a little.

Thanks

Curious isn’t it? An install of MS Office is about one GB but if I open Task Manager and look at Word it says it is using 21.4MB, Excel 14.7MB of memory. Is Office already loaded under another process all the time once installed?

The second window you open of a LibreOffice program will open much quicker than the first. If you open Writer then open Calc, Calc will open much quicker because the bulk of the program is already loaded.

What sort of problems rendering the page? Artefacts on the screen?

BTW, Windows Update Tuesday was this week, have you Restarted your PC since then? Frequently, Windows will act oddly until restarted after updates.

Thanks for the reply.

It seems to struggle rendering the menu bar across the top, after this the actual document opens. Yup, opening Writer first then Calc speeds up to almost no lag at all, its still there but not so much noticeable tbh.

In comparing to Word which loads all at once, Writer or Calc tends to load elements in stages (that’s the best way I can describe it).

Yup, received the update and restarted, all good there.

Hopefully I can jump across to Mint or Zorin soon, that’s my goal but had some issues with new Dell computer and UEFI setup, really fussy. This machine is a monster with 16GB RAM and huge graphics card along with flash 500GB hard drive, should absolutly fly on that :+1:

MS Office loads something on boot which is why it is so fast at opening, the downside is that you are using resources even when you don’t have office open.

There is an option during installation of LibreOffice to load LO at boot. I have never bothered enabling it as I can afford to wait two or three seconds the first time I open LO. The option is probably available somewhere still, else add it to start up programs in Windows management

Disabling the properties bar to right and using ‘single toolbar’ from user interface helps a little.

There’s a small thread about loading up in start up here how to automatic load on start-up

I’ll stick with it for the moment, cheers for feedback

I thought there would be a setting in LibreOffice: click Tools > Options > LibreOffice > General and under the heading LibreOffice Quickstarter tick the box Load LibreOffice on startup

Note that it will still delay by the 2 or 3 seconds anyway, just this time at startup.

Thanks bud, having used it for a bit now there are a couple of ongoing issues. Sometimes when typing into the cells directly there is a lag where nothing appears then it completes the text, at the same time auto spell checking highlights mistakes but the option from drop down right click to add or correct disappears.

I’ll try again on Linux next few days but may look at alternatives,.

Cheers

This problem manifested itself about a month ago after an “update?” of Windoze 10 while I was using OO and so I ditched OO and loaded LO and found that it was the same. However after reading that the problem appeared to be involved with the printer handling on another forum I investigated and found that if I set the default to the PDF printer, rather than an external printer, then all was sweetness and light. I hope that is of some help.