Libre office uses wrong GPU -> lagging experience. Fix?

I’m using version 7.1.3.2 and firstly, my setup is quite odd:
MSI laptop with 16gb ram, i7 8750H and GTX1060(GPU1) connected to an EXTERNAL MONITOR and the GTX 1060 is the GPU that is wired to the external monitor. The internal monitor (laptop screen) (wired to the Intel GPU) is disabled.

When the laptop is not connected to the monitor, it runs Libre Office fine and smoothly. But when using the external monitor, stuttering and lagging experience a alot!

After couple hours playing around with the computer, i found out that the problem was that everytime i run the software, it automatically selects the Intel Intergrated GPU HD630 (GPU0) instead of GTX1060(GPU1), even when the internal monitor is not turned on. By using the GPU0 in the screen displayed by the GPU1, it creates lag and stutter. LibreOffice is supposed to use the GPU1 when using the monitor displayed by GPU1.

I see no options in the software that allow me to switch the GPU:

My only solution right now is to untick the “Use Skia for all rendering” option. But when turn off this feature, the software no longer use any GPUs. Instead, it is powered by CPU entirely and consumes more CPU resources (but the experience is noticably improved).

So anyone can help me on how to force the software to select other GPU1 please!
Even the NVidia Control Panel prevents me from changing the options for this application. (Only this app, others OK!)

Also using the Windows setting doesn’t change the application’s GPU preference, it just stops using the Intel GPU and runs by CPU only!

Please file a bug report. Thanks!