LibreOffice Writer using Integrated GPU instead of Dedicated after monitor change

I recently updated my monitor layout. My laptop is now closed (laptop monitor off), while I have a dual monitor set-up: one 2K (1440p) screen and one vertical 1080p screen, respectively 165 and 144hz. Since then, my LibreOffice Writer has been rather laggy, especially noticeable when scrolling. I can now see, based on this topic (Libre office uses wrong GPU -> lagging experience. Fix?), that LibreOffice is using GPU 0 instead of GPU1, which might cause issues. (I could not find any discussions in the bug forum about this, but I may have missed it. The forum is not so easy to navigate for a newbie.)

Here are my installation details:

Version: (X86_64) / LibreOffice Community
Build ID: e19e193f88cd6c0525a17fb7a176ed8e6a3e2aa1
CPU threads: 8; OS: Windows 10.0 Build 22631; UI render: Skia/Vulkan; VCL: win
Locale: en-GB (nl_NL); UI: en-GB
Calc: threaded

I tried to disable Skia, but it did not necessarily make things work more smoothly. Scrolling was still really jagged. No crazy images or anything in the document, only 12 pages, with Zotero footnotes. Everything worked fine with this set-up before changing my monitor layout.

Many thanks for any help!

Try with:
Right-click on Star icon
Select Device Manager.
Select Display adapters.
Disable the device not to use.

Thank you, this has fixed the issue. Still would rather make changes on a per-app basis than for the entire workspace just because LibreOffice cannot utilise the correct GPU…

In the NVidia Control Panel, I can set soffice.bin to use High Performance NVidia Processor by clicking the Add button and navigating to soffice.bin, then selecting the appropriate processor. I can’t see any difference though.

Or, in Tools > Options > LibreOffice > View just tick the box Force Skia software rendering to get maybe better performance from the integrated graphics.

I have tried this for a while, but I got quite a few issues from disabling the integrated graphic card. Not sure if this is the best solution after all.