Libre Spreadsheet Errors (saving format)

I have to say I’m disappointed that I spent the whole morning building and filling a spreadsheet with contact names, addresses, emails, phone numbers, etc only to have the document ruined when I saved and closed it.

Reopening the document, it’s suddenly no longer in spreadsheet format, much of the information is missing and most of what remains is littered with underlines and strikethroughs making it nearly unreadable.

I’ve had the underlines and strikethroughs appear in text and rich text documents before as well.

It’s a real downer to see that an entire morning’s work is destroyed this way.

Does anyone have insite into how to prevent the problem from recurring in future documents?

Moved the question to the English category, tagged as calc.
You must save in ODF Spreadsheet (.ods) format.
ODF stand for Open Document Format.

1 Like

What format is it in? Maybe you could post a sample. Also, please give OS name and version and LibreOffice version.

With the current information, I would be inclined to suspect a failing HDD/bad sectors as the cause.

I already deleted the file, but as mentioned it’s not the first time it’s happened. I’m running the most current version of Libre, having installed the latest update this morning.

The strike through and underlining has happened before on text and rich text documents, too. I have a library just a couple blocks away so I usually will email a document to myself, then walk to the library to print it out. Generally, I only print a couple times per week, but they are usually fairly large jobs.

The underlining and strike through first happened with a document I had emailed myself to print. I figured it had something to do with having sent it through email, although I’ve been doing it this way for years now. So now I export to PDF before emailing it to myself to print later.

However it had done this again several times afterwards with rich text docs. Some had been saved and opened successfully, but later when opened again it had the underlines and strikethroughs, which were a pain to remove as they weren’t both consistent throughout the text. In other words, much of the text had both underlines and strikethroughs, but some only had one or the other (so I couldn’t just highlight the page and eliminate them, but had to go sometimes line by line).

It was the same thing really with this spread sheet this morning. It had been saved numerous times while editing it with no difficulty. But when I closed and opened it, wow! A hot mess!

I’ve since rebuilt the spreadsheet and re-entered all the data…and I just re-opened it again while typing this reply and it’s working now.

While I do appreciate your knowledgable input, I’m not a tech guy and wouldn’t know what to do about " failing HDD/bad sectors", but would hope that Libre reads these messages and figures out how to fix the bug in the program.

Thanks again for your thoughtful response!

There are two most current versions for Windows, the most current versions could be anything for other operating systems.

What operating system and version?

See This is the guide - How to use the Ask site? - #3 by Hrbrgr for how to supply information.

Is it still in email? Without a sample it is just guesswork. I cannot guess how unintended underlining and strikethrough occurs in a spreadsheet just by a change in save format.

RTF is a foreign format with reduced functionality compared to .odt, always save in LibreOffice native format

Like I said, I’m not a tech guy, so when I saw the icon, I clicked it and installed what it said was the newest version. Whatever one was at the top of the download page today.

I’m running Windows 10 Pro Version 22H2

If you can follow simple instructions you can seem like a techie :slight_smile: Go to the menu option Help and select About; all the information is there and you can copy it to the clipboard with a simple click on the Copy icon - two sheets of paper overlapping - to the right of the text Version Information and paste it here, thus (from my install):

Version: / LibreOffice Community
Build ID: 40(Build:2)
CPU threads: 16; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-US (wbp_AU.UTF-8); UI: en-US
SlackBuild for 7.4.4 by Eric Hameleers
Calc: threaded

Ok, I found the Libre version, The installed version is LibreOffice

It was saved in the Libre format. It was saved as Directory Database.ODS

Here is a cut/paste of the deleted spreadsheet rescued from the trash can. It doesn’t show the strikethroughs in the cut/paste, but the lines that have multiple “trills” before and after the line are the ones that had the strike throughs on the document.

Here is a cut/paste of the strikethroughs, although the whole page doesn’t have them. The strike through’s don’t show as strikethroughs when pasted here, but the lines that have multiple “trills” before and following the text are the lines that have strike throughs.

I got an error message saying, “New users can only post two links”, I’m guessing that’s due to the email addresses in the data, so I deleted those. Here’s the cut/paste with deleted emails

Here is a cut/paste of the strikethroughs, although the whole page doesn’t have them. The strike through’s don’t show as strikethroughs when pasted here, but the lines that have multiple “trills” before and following the text are the lines that have strike throughs.

Pasting doesn’t help.
My best guess now is that it is not a spreadsheet but a Writer document. On some documents you have inadvertently turned on Track Changes (Edit > Track changes > record). The crossings out are deletions and the underlining is additions. The “trills” are pipes | placed outside the margins to show where alterations have been made.

  1. Click Edit > Track Changes > Record (unhighlight it) to turn off Track Changes.
  2. Click Edit > Track Changes > Accept All to accept all changes.

Btw you should delete identifying details of others from your comment.

It started as a spreadsheet. I put the cells on the page and entered the data into the cells.

After saving the document as .ods I later opened it, the cells were gone and all the data was listed as if it were a text document.

I just checked “Edit>Track Changes>Record” and record was un-highlighted. I checked on the document in question as well as some other documents I’m still working on and it’s un-highlighted on all of them.

“Edit>Track Changes>Accept All” is greyed out and I’m not able to do anything with that.

“Edit>Track Changes>Show” was highlighted and I un-highlighted it.

Thanks for reminding me to delete the identifiying details from the earlier message and thanks for all your help and patience with a non-tech guy.

Good night.

The latest LO Fresh version is the LO 7.5.4, and the latest LO Still version is the LO 7.4.7 today.
I suggest you to use a Still version. Please read the informations on the Download page.

Thanks LeroyG, however it is saved as Directory Database.ODS

So, although saved as .ODS it is still all miscombobulated and a morning of work is lost.

Anyone else have any ideas on how to keep it from happening again?