LibreCalc Print Orientation Issue

I have designed labels in LibreCalc 2" in width by 1" in height, The page size is 2"x"1, and no matter what it shows and prints in the wrong orientation unless I changed the orientation manually each time I want to print.

I see the page which shows 2 inches in width, when I see the print preview it shows 2" inches in height while the orientation is Automatic, I have to put it in Portrait each time.

Unfortunately, I wasn’t able to make it work to be able to print it correctly without changing the orientation manually. I appreciate any solution.

Version: (x64) / LibreOffice Community
Build ID: 728fec16bd5f605073805c3c9e7c4212a0120dc5
CPU threads: 8; OS: Windows 10.0 Build 22000; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

Can you upload an ODF type sample file here?

Here is the file, I use the SKU sheet for print.

sku.ods (22.3 KB)

Menu / Format / Page Style.
Orientation: change to Portrait.
Please try.

Thank you for the reply, I have already done that, but still the same problem.
As you see in the attached picture, when I change it to portrait, the width will change to 1", if put it on the landscape, the width will be 2" which is correct (my labels are 2" width x 1" height), but when I print, I have to put it on the portrait to print correctly.

It works for me with the Misrosoft PDF printer in my LibreOffice 6.1.6. and in my LO 7.3.4 Portable version:
Print1 : portrait,
Print2: landscape
Print2.pdf (45.3 KB)
Print1.pdf (45.4 KB)

I think you should report a bug, How to Report Bugs in LibreOffice - The Document Foundation Wiki

There was a similar question a while ago, it took me a day to remember the name of the printer so I could find it, Libreoffice Zebra GK420t Can not set the correct page settings #writer . It seems a change happened around LO 6.1

I don’t have your printer driver and I can’t use a physical printer because the paper size is too small for my printers; I used Bullzip PDF but Adobe PDF is the same. Presumably, your printer driver rotates the portrait to landscape for printing.

As with you, I had to change to portrait before I could see the correct image in the preview pane of the Print dialogue window. Even then, the Paper size field was incorrect, although the preview pane gave the correct dimensions.

I printed as Portrait, as Landscape and Exported to pdf
sku79511Portrait.pdf (14.0 KB)
sku79511Landscape.pdf (12.9 KB)
sku79511Export.pdf (13.8 KB)

BTW you might like to look at this question which is not related to your question, Add 1D barcode images based on cell contents

1 Like

Actually, when I change the page style on portrait, on print preview, changing between automatic, portrait and landscape has no effect. It’s the exact wrong position.
But, when I change the page style to landscape, on print preview, the only way to get it right is to put it on portrait manually.

Don’t forget to report the bug number back here. Cheers, Al

I’ve found a similar bug reported: (Actually I have the same issue too)

146047 – UI: Orientation Landscape in Print dialog doesn’t do anything (

I don’t think bug 146047 applies; it is resolved and earliest version is alpha1. Comment 10 in that bug says the setting is for more than one page per sheet