LibreOffice Install Fails

While I have found a resolution, I’m curious about the installer for (x86) and its failure to install on Windows 10.

I conducted an upgraded for (x86) the other day and the install failed. The error received was “Error 1335. The cabinet file ‘’ required for installation is corrupt and cannot be used.”

I tried a number of approaches posted, including installing LibreOffice using admin permissions granted through the registry and command line using msiexec /a. All resulted in the same error.

However, as I stated above, I did find a fix. But it required either installing LibreOffice 5.1.6 (x86) [Still] or LibreOffice (x64) [Fresh]. The x64 version must be downloaded by scrolling down to the “Available Versions” section on the Fresh version download page, the default download is to x86. I did not need to use admin switches or run as commands when installing these versions.

So this raises a few questions:

  1. Is the (x86) installer for Windows corrupt?
  2. Why would it make a difference in the level of success installing these different versions?
  3. How do I find an archived version of an installer for a prior version of LibreOffice? I couldn’t find version after a long search.


(Edited for more clarity. Cf. Comment by @rautamiekka) or ? You use both interchangeably, but I know LibreOffice existed as 3.0 the first time, meaning there’s no LO 2.x. Anyway, try to fix your typos.

As far as I can remember the very first version released by TheDocumentFoundation got named LibO V3.3.

@Lupp: Likely it was. I didn’t check for the exact version, but I know there was no such thing as LO 2.x.x, while 3.x.x was.

edited: 20161204

I don’t remember an issue like this for me, and I install several LO for test at week, and I have Win10 since it was released.

I remember people having issues downloading with IE, I always use FireFox with DownThemAll extension.

You can find all versions for all OS on: Index of /libreoffice/old

@M.A.Riosv, thanks for the response. However it looks to be a chronic issue for LibreOffice. The links within the links, point out this issue has been going on for years (start of Libre project?). Some of the links state there was file corruptions with response with fixes from the community fixing the issue, others point to Windows permissions, for rollbacks there are links pointing external download sites. Sadly this didn’t address the questions I posted above. Especially questions 2 and 3.