LibreOffice 5 keeps crashing

When upgrading from Build ID: Arch Linux build-2 to LO5 5.0.1-1, the program keeps crashing after a few minutes or actions. One of the actions is when trying to select or change a text color, but also when using other functions, tools or changing text properties. But the crashes also occur after having used the program for a few minutes.

I have removed previous profiles and removed any data left after installing 4.4.5. before upgrading. Although, it seems there are still some hidden files left in the system that are reused by LO5 after installing.

Currently I have downgraded to 4.4.5 again because it is really frustrating to have to restart the program every 2~5 minutes.

does anybody have an idea how I can solve this problem?


Please add your OS + any error message.

My LibreOffice 5.0 does not crash so often, but it does crash more often than 4.4.5. And for no obvious reason. For example, few minutes ago I finished my document, saved it and I tried to close the program. And it crashed (Ubuntu 14.04 LTS).

…it happens daily… last time I used it, I was trying to click on some menu item in View (later, when restarted, this option was working but this caused the LO 5.0 to crash). Is possible to seperate instances of LO Writer, Calc, Impress and Draw. Because, when one program crashes, other crashes to.

it is certainly doing it for me. I thought it was just Calc but now I have a writer file that is dropping every time i try to select inside a table

I have this problem too. I recently upgraded from LO 4 to LO5 in Debian testing. Now, LO crashes almost every time that I click on a toolbar control that brings up a pallet, such as text or background color. LO version “” on Debian Linux 4.1.0-2-686-pae #1 SMP Debian 4.1.6-1 (2015-08-23) i686 GNU/Linux. I am using FVWM as the window manager.

Upgraded a laptop and a desktop to Ubuntu 15.10, which brought in Libreoffice Both machines suffer crashes when running Libreoffice, sometimes repeatable (for example one machine crashes when two documents are open and I try to switch which document I am viewing). Other times crashes are random, and can happen without actually doing anything in Libreoffice (perhaps autosave triggers crash).

I have a fresh install, but reinstalled it because it crashed often. Renaming the user folder and having LO create a new one did not help either. Fresh install and new user profile and it still crashes completely at random, some times it takes the whole OS with it!

Version: Build ID: 1:5.1.4-0ubuntu1
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default;
Locale: en-US (en_US.UTF-8

LibreOffice in Debian testing just updated to package version 1:5.0.1-2 and the problem is gone for me.

Many thanks for your report.

I suffered from this problem as well. The problem in my case was the default GTK3 library that LibreOffice wants to use isn’t fully compatible. Forcing LO to use GTK2 by running it as follows fixed it for me:

SAL_USE_VCLPLUGIN=gtk lowriter (localc ... etc)

If that helps, the Arch wiki page for LO gives instructions for making this change permanent for all LO applications by editing a shell configuration file or


Simiar issue on Linux Mint 17.3 Rosa, Writer itself crashes at startup, unless another LO App is open. Then it works just fine. Very annoying, as I seldom use the other apps, although sometimes I use localc alot…but usually just lowriter.

This is on a clean install. Have asked around on the net, several other people with the same issue on Mint and Ubuntu.
No permanent fix, just the workaround of starting localc or some other app first. (Have tried the GTK fix, did not work for me.)

Same issue for me with Linux Mint 17.3 also. But it crashes generally when I click on a file in Nemo. Sometimes it can be resolved by first opening Writer or Calc and then open the file from there. But it is a strange bug, which was not there in Linuc Mint 17.2 with Libreoffice 4.x

I am having the same problem with Version running on Windows 10. It crashes very often, though not always, when saving a writer document, and either can’t recover or there is next to nothing there after recovery. I tried the mentioned workaround of having another app open and that works, but this bug should be squashed once and for all.

Can you specify, which type of operating system are you using? So that can provide you the exact steps.

I am not OP but but I am running Arch Linux and its dropping out VERY frequently as well.

I should also say that OP lists that his OS is Arch in the VERY FIRST sentence of his post.

OP’s system is Arch linux. It’s a rolling distribution. My OS is also Arch Linux, kernel/linux 4.1.6-1. LibreOffice version 5.0.1-1 instaled from package ‘libreoffice-fresh’. Calc often crashes. And it ALWAYS crushes whenever I want to edit.create a macro. Downgrading to helps.

Did you try to disable OpenCL in Settings? I think this was new in L.O. 5.0 and it is realted how Calc re-calculate values in cells…

As an experiment I removed directory ~/.config/libreoffice/4/user and was able to open a macro for edit for the very first time.