LibreOffice 6.2 can't save to samba share


I am using Ubuntu 18.04 LTS and recently moved to LibreOffice 6.2 from 6.1.

When I used 6.1 there were no issues in opening and saving files directly to Samba (Windows) shared location. After upgrading to LibreOffice 6.2 I can’t save to a Samba location as I get an error:

Common input / output error

There has been no changes in my samba configuration which worked perfectly fine with LibreOffice 6.1. Also, due to how my share works (and I have no control over it as it’s managed by my office’s IT manager) I have to have in my smb.conf the following:

min protocol = SMB2
max protocol = SMB2

I can’t change these protocols, otherwise my shares will no longer work with my Desktop.

What’s interesting is that LibreOffice 6.1 worked without issues so it seems 6.2 has some sort of bug or incompatibility with SMB2 protocol?

Any help is appreciated.

Thanks in advance.

Your question is a bit confusing, since you write you are using SAMBA shares, but put “Windows” in parentheses. Windows doesn’t provide SAMBA - so you must have some kind of a *NIX server, which implements SAMBA. And that’s another strange thing. Both ends of the communication are *NIX systems (your Ubuntu client and the *NIX Samba server) and you are using a Windows type protocol instead of some *NIX network filesystem. But anyway, without having any mount options for your mount -t cifs it will be hard to support by implementing the same situation on a test system.

Sorry for the confusion.

I will explain better: I am using an Ubuntu Desktop 18.04 laptop myself and I am trying to save on a Windows 2013 server where my documents are stored. I am using Samba myself (so my endpoint is Ubuntu and the other one is Windows 2013).

I don’t have anything mounted, I simply use SMB configuration to access the Windows shared drive whenever I need and I always used it this way since I work on this office and with LibreOffice 6.1 it did work.

This explanation doesn’t make it much better, because if you have a Windows Server for the shares any local SAMBA server configuration (i.e. your Ubuntu’s smb.conf) doesn’t play any role. And if you haven’t anything mounted from your Windows Server (Windows people prefer to use the phrase “shared” instead of “mounted”) then it is obvious that you get an error. No mount → no network filesystem (or no share) → nothing can be stored on the server. It might be a good idea you provide an output of mount | grep cifs form your Ubuntu system.

I can confirm this problem. My workstation is running Fedora 30, communicating with a Fedora server (don’t give me any grief – I’m free to run my server however I wish). The rest of the office is Windows and Mac, so the server shares are managed via Samba server, and my workstation is mounting those shares via gvfs. After upgrading from 6.1 to 6.2, I get the “Error saving the document: bla: Nonexistent file” whenever I try to save a newly created document to the share. I have to save locally and then copy to the share. Opening and editing files from the share works as expected, with no errors.

It sounds like the problem isn’t with the server but with LibreOffice and CIFS mounts…

similar problem here, accessing a share on a ‘Fritz! Box’ from a Win7 SP1 machine per LAN or through a VPN, folder mapped by ‘net use …’, file and folder access is ok despite sometimes laggy and slow, saving files by LO calc often works, but frequently false! complaints about rights, space, missing files, ‘file in use by other’, ‘file already open by yourself’, ‘general input/output error’ or whatever, saving local and copying by file manger works … thus LO has a problem?, versions used: and plenty flavours from 7.0 and 7.1

Probably tdf#123472, likely fixed in LibreOffice 6.2.4

I think I have the same problem:

Libreoffice Version 6.2.2-0ubuntu0.18.04.1~lo1
Samba server on debian 2:4.5.16+dfsg-1+deb9u1
mount samba share via gvfs

I can read a file, save it but not save a new file or perform a save as:

Error saving the document: bla: Nonexistent file

I’m not sure but it worked before and thus assume that it worked with Libreoffice 6.1.x

Thanks for any suggestions

Did you notice that OP is saving to Windows Server and thus your problem cannot be the same? OP may claim to use SAMBA as many times he wants to, but SAMBA is not involved in his case.

And please: Do not use “Answer”, if it is not an answer to the original question. This site is intended to be a Q&A site.

Dear Opaque,
Even if heldmar is saving to a windows server I must assume that the problem is on the linux client side.

Sorry that I used answer instead of comment. I saw my error when already hit the “send” button. And did not know how to undo it.

I have run into this save problem for my Linux clients. Windows client works fine. My server is Ubuntu 16.04 running samba and nothing has been changed on it. My client is Linux mint 19. After upgrading to Libreoffice 6.2.3 from 6.1, I can no longer create a new file, though an existing file can be updated.

mounting the share manually like this worked for me

mount ///SMBshare /mnt/smbshare -ouid=localuid,user=remoteuser

Same thing here, after update to 6.2.2:

Libreoffice 6.2.2. can’t save a new file to NAS via smb, while other versions still can.
Libreoffice 6.2.2. ALSO can’t save a new file to linux-server via smb, while other versions still can.
Protcol is smb (smb://192.168.x.x)
Overwriting existing files is no problem.

First error message:
Error saving the document test: Nonexistent file

Second error message:
Error saving the document test: General Error. General input/output error.

Seems to be same problem as here:

I use the following method to save new LibreOffice files to the local area network using LibreOffice version This method uses the File>Save Remote… option.

On selection of the Save Remote… option, a Remote Files dialogue window presents with a list button to Add Service for a network share. I left click on the Add Service button which then displays a File Services dialogue window that contains a drop down list for Type.

The drop down Type list on the File Services window allows me to select window’s share for Type after which the File Service dialogue window expands to include fields for a Host computer and share name.

For the Host field, I specify the name of my NAS storage device and in the Share field, I enter a share name (I have only one) defined on that device. I also put the share name in the label field (optional) presented on the File Services dialogue window and then click the OK button. I don’t specify a User or password because I deliberately set Samba up on the NAS box to work with anonymous connections (I like it that way).

On the ensuing Remote Files dialogue window, I’m presented a tree diagram of the network share I supplied earlier. In the left pane, I can drill down to the desired directory and then specify what File name to use to save the file when I click the save button.

The intuitive solution to use File>Save>Other locations option just didn’t seem to work initially. I could not navigate past the share name presented when I selected the remote computer displayed with the Other Locations option. I would get an error indicating “Could not read the contents of Share_Name”, “Not a directory.”

However, after I added the service using the Remote Files dialogue, that service then appeared under other locations allowing me to save files via the Files>Save>Other Locations option by selecting the service.

This worked for me. Using LibreOffice on Ubuntu 18.04, I was able to save a spreadsheet to the Windows network share. I was saving as csv. Initially it gave me “file does not exist” error, but then returned me to the dialogue confirming that I wanted to save in csv, and the file was created on the network share.