LibreOffice 6.3.6 and 6.4.3 both fail to launch in macOS Catalina 10.15.4

I know, I know, a lot of people seem to have problems launching LibreOffice on macOS Catalina. I’ve seen many other posts here and I’ve already read this document: LibreOffice and macOS Catalina. I’ll be very happy to be proven wrong, but I don’t think my issue is the same thing. I am right-clicking the app and choosing Open, as most answers here and the aforementioned support document instruct me to do.

My issue is the app launches and immediately quits without any error message. The issue most people have is accompanied by a message about the app not having been opened because the developer couldn’t be verified, but mine just fails to launch silently. I opened the Console to try and see any hint of what might be going on, and there I see these messages:

default	22:28:19.914235-0600	Finder	LAUNCHING:0x0-0x70070 LibreOffice foreground=1 bringForward=1 seed=168 userActivityCount=0
default	22:28:19.923224-0600	loginwindow	-[PersistentAppsSupport applicationReady:] | App: LibreOffice, ready, updating active tracking timer
default	22:28:19.923266-0600	loginwindow	-[ApplicationManager checkInAppContext:eventData:] | ApplicationManager: Checked in app : LibreOffice
default	22:28:19.927911-0600	distnoted	register name: com.apple.sharedfilelist.change object: com.apple.LSSharedFileList.ApplicationRecentDocuments/org.libreoffice.script token: f42f0 pid: 786
default	22:28:19.994793-0600	soffice	FRONTLOGGING: version 1
default	22:28:19.994807-0600	soffice	Registering, pid=4305
default	22:28:19.997220-0600	soffice	CHECKIN: pid=4305
default	22:28:20.012094-0600	launchservicesd	CHECKIN:0x0-0x70070 4305 org.libreoffice.script
default	22:28:20.012557-0600	loginwindow	-[ApplicationManager checkInAppContext:eventData:] | ApplicationManager: Checked in app : LibreOffice
default	22:28:20.012727-0600	lockoutagent	Requesting policy for bundle IDs: ( "org.libreoffice.script" )
default	22:28:20.013031-0600	soffice	CHECKEDIN: pid=4305 asn=0x0-0x70070 foreground=1
default	22:28:20.014415-0600	lockoutagent	Requested application <private> has policy 0, associated category:DH1005 associated sites:(null) equivalent bundle identifiers:org.libreoffice.script
default	22:28:20.024036-0600	soffice	Registered, pid=4305 ASN=0x0,0x70070
default	22:28:20.024220-0600	soffice	Registered, pid=4305 cgConnectionID=4b03b
default	22:28:20.027112-0600	soffice	BringForward: pid=4305 asn=0x0-0x70070 bringForward=1 foreground=1 uiElement=0 launchedByLS=1 modifiersCount=1 allDisabled=0
default	22:28:20.027596-0600	soffice	BringFrontModifier: pid=4305 asn=0x0-0x70070 Modifier 0 hideAfter=0 hideOthers=0 dontMakeFrontmost=0 mouseDown=0/0 seed=0/0
default	22:28:20.027915-0600	soffice	BringForward: pid=4305 asn=0x0-0x70070
default	22:28:20.028075-0600	soffice	SetFrontProcess: asn=0x0-0x70070 options=0
default	22:28:20.035331-0600	soffice	Current system appearance, (HLTB: 1), (SLS: 0)
default	22:28:20.040026-0600	soffice	Post-registration system appearance: (HLTB: 1)
default	22:28:20.053836-0600	distnoted	register name: com.apple.xctest.FakeForceTouchDevice object: org.libreoffice.script token: f4268 pid: 4305
default	22:28:20.124774-0600	soffice	Registering for test daemon availability notify post.
default	22:28:20.124890-0600	soffice	notify_get_state check indicated test daemon not ready.
default	22:28:20.133425-0600	soffice	SignalReady: pid=4305 asn=0x0-0x70070
default	22:28:20.136161-0600	soffice	SIGNAL: pid=4305 asn=0x0x-0x458864
default	22:28:20.152414-0600	tccd	-[TCCDAccessIdentity staticCode]: static code for: identifier org.libreoffice.script, type: 0: 0x7fc7a8a2f370 at /Users/joseph.day/Applications/LibreOffice.app
default	22:28:20.154602-0600	soffice	NSApp cache appearance: -NSRequiresAquaSystemAppearance: 1 -appearance: (null) -effectiveAppearance: <NSCompositeAppearance: 0x60000390e100 ( "<NSAquaAppearance: 0x600003909d00>", "<NSSystemAppearance: 0x600003909900>" )>
default	22:28:20.157393-0600	distnoted	register name: com.apple.nsquiet_safe_quit_give_reason object: org.libreoffice.script token: f429c pid: 4305
default	22:28:20.306394-0600	loginwindow	-[PersistentAppsSupport applicationQuit:] | for app:LibreOffice, _appTrackingState = 2
default	22:28:20.306421-0600	loginwindow	-[PersistentAppsSupport applicationQuit:] | App: LibreOffice, quit, updating active tracking timer

The last three messages seem relevant, I’m just not sure what they mean. Hoping someone here can make heads or tails of this. Thanks.

Have you already tried to provide Full Disk Access to LibreOffice.app?

FINALLY someone with the same problem I have.
.
Kindaoff, at least : on mine, I have this log entry on the Console before soffice quits:
.

Connection removed: IOHIDEventSystemConnection uuid:AAA750A8-3D3C-4F69-9F8A-1A0E9CDD73CD pid:1618 process:soffice type:Passive entitlements:0x0 caller:HIToolbox: ___GetIOHIDEventSystemClient_block_invoke + 26 attributes:(null) inactive:0

.
All my LibreOffices (and OpenOffices) are suffering from this problem since July (more or less), on my both Macs: one with Sierra, other with Mojave. All of them suddenly stop working, besides I had not updated LibreOffice since the last time I used it some weeks before.
.
Both machines stopped running LibreOffice (and OpenOffice) at the very same time. I suspect something on MacOS itself.
.
New versions of LibreOffice didn’t solved the problem.
.
Disabling Gatekeeper didn’t solved the problem.
.
Enabling Full Disk Access on Mojave didn’t fixed the problem.
.
Moving the LibreOffice.app out of the /Applications didn’t solved the problem - I tried o ~/Applications, and to ~/bin .
.
Deleting the LibreOffice.app/Contents/_CodeSignature didn’t solved the problem.
.
using codesign with my own key after, didn’t solved the problem.
.
I’m open for suggestions, I need to use this thing!