LibreOffice 7.2 and 7.3 freeze/crash editing macOS Calc Spreadsheets

Ever since updating to 7.2 (and also with 7.3), LibreOffice routinely freezes when editing in Calc Spreadsheets. The app becomes unresponsive and I get the spinning beachball. I’ve left it for 30 minutes with no resolution.

This seems to perhaps happen more frequently after pasting data from one open sheet to another, though I can’t say for sure. I can say that it happens frequently enough that if I don’t Command-S every 30 seconds, I will lose data almost certainly.

Rolling back to 7.1 resolves this.

I have this issue on both M1 and Intel Macs, all running Mojave.

I have not noticed any extra instability using LO 7.2.5 on a MacBook Air with Catalina (release right after Mojave), for what that is worth.

Try one or both parts from answer at LibreOffice 7.3.0.3 unstable Cheers, Al

[Edit] Sorry I misread. Try Computation related issues in Calc First steps to take before submitting a bug - The Document Foundation Wiki

I have tried all the solutions suggested thus far, but both OpenCL and Skia were already disabled.

The issue happens when I copy a formula to the clipboard and then switch to a different sheet (in the same document or a different document). Maybe that helps?

Do you have a clipboard management tool installed? They frequently cause problems.

1 Like

@EarnestAl Yes, I definitely do… and I can’t imagine life without one. I use Keyboard Maestro on the Mac here. To be fair, though, this happens even if I’m not using something from the Clipboard Stack.

This path routinely causes a freeze:

  1. Copy (Command-C) formula to main clipboard
  2. Switch to another sheet (in same workbook or different workbook)
  3. Paste (Command-V).

One thing which mitigates it is putting in a step 1a and 2a, both of which are “Command-S to save current document”. So I’m obsessively saving (to mitigate any data loss), but doing so seems to ‘reset’ whatever causes the spin-of-death, and generally keeps things flowing smoothly.

And, again, this is new with 7.2.x builds and forward. 7.1.x (and prior) work great, without any need to obsessively save.

The clipboard manager intercepts the copy regardless and reinterprets it.

I can’t help with this, sorry.

Ok. Thanks for the tip! I’ve disabled Clipboard Management for LibreOffice. I’ll continue to test and we’ll see if that’s it.

For what it’s worth, this wasn’t an issue in 7.1, so clearly it is doable for these things to co-exist if that’s the issue here. I’ll report back!

There were a number of Paste bug-fixes for LibreOffice in version 7.2, in the same release notes see: