Libreoffice base and java functions

i had made a database , libre office base , with jre java 6. It works ok. I was wondering if there is any way to convert this to work with latest java jre,
at this time is released java Version 8 Update 171

if i select the java version 8 the base crashed

is there any conflict about table structures , or i should write the code from the scratch?

i m using Ubuntu 16.04.4 LTS (Xenial Xerus) 32bit, with base

any idea ??

Hello @warningdangerous,

Please do not select Post as wiki when posting a question. It helps no one.


To be clear, the latest version of Java is 10. This works on Linux Mint 18.3 and others. Have seen many problems with this using various Windows OS products. Seems JRE 8u172 works (see answers & comments in this post → Cannot open BASE files.. Mac needs JDK.

You do not state your OS nor the LO version you are using. Basic information is always essential to help diagnose problems.


Have not got much on 32-bit Linux systems. This post may help → How do I get Base to work under Lubuntu 16.04?. Please review all that is there. Also, LO v5.1.6.2 is very old. Consider upgrading.

tdf#108619 ?

@mikekaganski TY - had not seen. Workaround seems to be same as link in edited answer. Down side it seems to affect v5.2.7.2 and newer & this post refers to v5.1.6.2

Well - there’s a backtrace for there also; and I believe that that bug is not specific to any LO version actually, because it’s about Java interaction with kernels, when running specific methods, that were used in initialization of Java in LO since ~forever :slight_smile:

And yes - your last link is exactly for that, so your reply covers it all; I just added a big link.

Thanks. Always appreciate the info & your helpful explanations.

ok, lets say that there is a bug
i have my ububtu system fully updated and thru ubuntu software update center this is the latest LO version.
Do you know if there are any LibreOffice Repositories to add ?

There is a bug in Java on 32-bit kernels, that Java developers refuse to fix, especially they have dumped 32-bit support, as well as many Linux distros. What do you expect from any LibreOffice repo, which doesn’t have anything to do with neither Java nor kernel nor their interaction? The link above, which we discussed above, does contain the workaround to use…

thats means the end of 32 bit …
i will try a format and 64 bit installation , i hope to be lucky…

i tried several lunux distros x64. Yes, the java seems works, but i had a lot of visual basic code errors. My code has no errors. I tried win7 x32bit and worked!!
With Wndows my probems are gone…

So there is a small bug to linux kernels 64bit also…

what kind of “visual basic code errors”? was it that it wasn’t able to CreateObject() or something that depends on Windows-only functionality? anyway - feel free to file a bug report on this different problem.

oh wtf … this bug is complicated …

Ubuntu Report

LibreOffice Report

Kernel Report LKML: Ben Hutchings: Re: [PATCH] mm: larger stack guard gap, between vmas

Problematic Code Re: [PATCH] mm: larger stack guard gap, between vmas

I tried win7 x32bit and worked!! With Windows my probems are gone…

the code is right and it is tested, is working at Windows7 at this moment … (Solved)

but at linux the same odb (LibreOffice Base file) , apears strange errors of Basic Runtime Error …

Anyway , i solve this problem by changing Operating system platform …
its somethig about java and linux kernels