LibreOffice Base failing under Big Sur for Mac

I upgraded my Mac to Big Sur, version 11.1 On Mac mini (Late 2014)

LibreOffice failed to run - appeared to start and then failed. Installed new LibreOffice

Build ID: 639b8ac485750d5696d7590a72ef1b496725cfb5

Note: The same steps shown below failed using LibreOffice 7.0.3 MacOS x86-64.dmg

Tried to connect to my database. Got the message others have seen

The LibreOffice configuration has been changed. Under LibreOffice - Preferences - LibreOffice - Advanced,
select the Java runtime environment you want to have used by LibreOffice.

When I try this, no Java runtime shows up in the list.
Tried unclicking ‘Use a Java Runtime Environment’
Slightly different behavior

The connection to the data source "PSAMembers" could not be established.  No SDBC driver was found for the URL 'sdbc:embedded:hsqldb'.

I installed the latest Java v. 8 from Oracle

In the Java Control Panel / Java / View it shows Java Runtime Environment Settings for System as

Path = /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java

Returned to Libreoffice preferences, but could not navigate past the ‘Internet Plug-Ins’ folder in the ‘Add’ command

I saw some comments about adding a missing libreoffice-sdbc-hsqldb - not sure how to add this.

Mac to Big Sur, version 11.1

There is no macOS 11.1 - Big Sur is 11.0 (current sub-release 11.0.1)

> I installed the latest Java v. 8 from Oracle

Did you really install JDK, which is required on macOS - see FAQ? Your path doesn’t look like the install path of JDK but install path of a JRE (be aware, if being on LibreOffice version 7.0.x - you need to use JDK 12.0.2 - others don’t work).

> I saw some comments about adding a missing libreoffice-sdbc-hsqldb

This is applicable to GNU/Linux systems only. On macOS all required software gets installed while installing from dmg file (the only exceptions to this are language files, if you require another UI language than “English (USA)”.

I got a Macbook Air M1 on Dec 25 with 11.0.1, updated it to 11.1, wouldn’t run, downloaded 7.0.3 (already downloaded), would. Options - Libre Office Advance → Java Options showed Oracle Corporation 1.8.0_20, selected it. Location shown as /Library/Java/JavaVirtualMacMachines/jdk1_8.0_201.jdk/Contents/Home/jre . The java was loaded by the Migration from OS X 10.11.6 (El Capitan). I think the /Library/Internet Plug-ins/JavaAppletPlugin.plugin is a bundle.


Your issue is: You need a special version of java: JDK 12.0.2 - see bug report tdf#135479 - LO Complains about missing JDK when accessing any Java functionality, despite recognizing JDK on macOS under Preferences - Even if yours shows up in LibreOffice - it won’t work due to the bug mentioned above (which also might be the solution for OP, who did not respond to my comment hence the current status is unclear).

@anon73440385 I apologize for my idiomatic English. The combination LibreOffice, Oracle jdk 1.8.0_201 and macOS 11.1 on the Macbook Air M1 works. The comment was meant to suggest places to look and that the Plug-in wasn’t appropriate.

Oracle jdk 1.8.0_201 and macOS 11.1 on the Macbook Air M1 works

Are you sure? Are you really using it? The issue is not LibreOffice not recognizing that version but the issue is to get an error about a defect Java installation when using it. Anyway - did not find that old 201 release at Oracle’s website, hence cannot test.

My MacBook has, as at 26 Dec 20, 11.1 Big Sur.
C:\fakepath\Screenshot 2020-12-26 at 10.56.56.png

I’m unable (lack of competence) to attach to this text the actual pictorial screenshot showing the “About this Mac” with OS 11.1 shown.
The second line is what occurs when I try to attach it. Hope this is clear.

(Edit: activated screenshot -AK)

You should edit your question and add the information or add a comment, this is not a solution to your question.