Libreoffice Base freezes/corrupts simple database

Hi, been using Libreoffice to build a very simple database with only about 5 tables.
It regularly goes very slow, at which point I know to save everything and exit and re-load Libreoffice. If I don’t do that, eventually the whole thing will freeze, and I will have to do a force quit.

In addition on the forms I have created within Libreoffice Base - I will be working away happily, come out of a form, go back to re-open that form and I get: The document ‘documentname’ could not be opened. sfxBaseModel:loadfromStorage: 0xf26.
It is getting pretty tedious having to write and re-write forms (almost on a daily basis)

I don’t have a split database - I’ve tried every option, including the wizard online, to try to split it, but the system just keeps freezing.

I am getting to the point where I will have to dump Libreoffice soon and go for something else, as its getting a bit ridiculous how often the system is either dumping me out, or corrupting stuff. On the other hand, I’m frustrated as essentially its a fantastic free system, and I’ve started doing some programming to make it work well.(msAccess ex programmer).

I’ve searched everywhere to see what could be causing this, but am at the end of the line. Currently running which I think is the most recent version.
any pointers much appreciated

FURTHER INFO, thanks for the 1st answer:

Hi, THank you for your quick response.
I can’t really attached the DB as its full of sales and invoice info.

No images at all in any tables.
Basically only three tables, straightforward Invoices (10 fields) and Suppliers (4 fields), Sales (8 fields) Currently 600 records in invoices, 83 Suppliers, so pretty tiny really. Sales is a little larger at 6000 or so. As you can see they are really small - I don’t want to get more complex until I know its stable.

I will try again with the Split DB. I had trouble once I opened the Wizard DB, as at that point it just hangs and won’t do anything. Can’t quit, can’t do anything with that DB (if I have another DB open, I seem to be able to use that one). I couldn’t quite work out what it was trying to do.
And so I go round and round - trying again and again! Am familiar with using Split DB from MS Access days, so understand the theory, although appreciate that Libreoffice probably does things slightly differently.

OS Is Mac OS Sierra. In Libreoffice Options / Advanced it says JRE Oracle Corp 1.8.0_121. Nothing else in there.

So far as coding goes, these problems have happened from day one - before I started delving into coding. Have set up a test DB for the coding, so actually there is no coding in this DB. I would be using Access2Base as its the most familiar to me.

As I said, I would like to continue with LO if at all possible, as I’ve now got to grips with how forms work, and there isn’t much out there for Macs for simple databases, so this seemed to suit our needs very well.

Much appreciate any info you can give me. Maybe I need to persevere with the split DB, but keep coming up against that hanging database thing. I have literally spent hours… :slight_smile:
Thanks again Becky

BTW I am using this at work and at home, both on same OS versions, both same LO versions, so don’t think that this can be machine-dependent. Same problems on both machines.


Based upon your question it is not clear as to what the cause of your problem is. Use of the HSQL embedded database is always advised against. It is good for education, testing and samples but not for regular use. Corruption can occur especially when embedding images in a table (as little as 5-7 images total) or large amounts of data. You also state doing some programming. Have seen this occasionally be the cause. Errant code. Using a split DB minimally is a start.

If you are having problems splitting the DB, try my instructions provided in Split DB setup instructions.

Also, it may help to know more about the code you are using and the data you are dealing with. Another piece of info missing is what OS you are using & the Java info - JRE or JDK & version number. Are you coding with Access2Base, Basic, Python etc.? Do you have problems without any code? Are you embedding images?

If possible, posting a copy of your .odb may help provided you do not include any personal or confidential info.

Thank you - have added further info against original question. Apols for creating another answer…

Don’t know if you received my last comment as you were quick to modify/delete the answer.

I’ll restate. The concern I have is your Java install. It may be incorrect, accounting for all your problems. Install the latest JDK from Oracle. Once installed verified it is selected in Advanced section. Mac needs JDK (contains JRE) for OS verification. Confusing since Base should not work at all (which may be why split simply hangs) with incorrect Java.

Great, I will try that. Maybe I’m lucky that anything has worked thus far … Sorry I know nothing about JDK/JRE or what it does, but that sounds like something concrete to work on. Many thanks Becky

@Adlib Just wanted to clarify a point about split DB. Not what you had in Access. In Base, embedded version, the data is contained in the .odb (along with many other zipped files). Somewhat the same as Access. Split simply removes these from the .odb and utilizes them externally. Additionally the split process upgrades the HSQLDB to a newer version. All this is then contained in its’ own directory. In Access you are simply placing the tables in another .mdb. Apples & Oranges.

@Adlib Just a friendly reminder - please do not use answer for response. Either use comment or include in original question.

At this point, the only other thing I can recommend is based on a possible with the User Profile which can occasionally have adverse effects on LO. If you haven’t done so already, try Restarting in Safe Mode. You should find this under the the menu item Help.

Related & additional info on resetting the User Profile can be found here.

If using Ubuntu on Linux, you might consider switching to PostgreSQL as the DBMS instead of using the the more limited embedded databases supported by LO. Save the spreadsheet as a tab-delimited file, create a table using SQL, then use the psql \copy command to pull the data into the table. You also get to use the more robust pgAdmin utility to query and manage the data.

Hello again,
Despite having the most recent JDK (see screen print - where it says Location underneath, it specifies the JDK ), I am having the same problems.
I know that ‘use a JAVA runtime environment’ is ticked, but if I untick that, nothing works at all!
(I know there are two of them on there for some reason - probably trying to get it to work. The version at home is same, except it only has one JDK showing, and that’s not working either)

Is there something else, somewhere else, that I need to change?

I was having corrupt forms on a daily basis, and have given up using forms at all now, as i keep having to recreate them. The wizard still hangs,and just sits there when I attempt to split the database.Much appreciate the info on split databases and how they differ from MS Access.

Delay in coming back to this as have been on other projects.
Any help offered much appreciated.