LibreOffice CALC crashing under Windows 11

In a new computer, i7 12700K, 32 GB DDR4, NVidia 1650, Windows 11 64bits
I tried to open previous .ods documents (from few days ago) and LibreOffice crashes every time.
The .ods files are not corrupted because Excel can open them.

LibreOffice Writer and Presentation are working OK.

Can you attach an example corrupt document to your original post please?

1 Like

Hello ,

Thanks for your answer.

As I already said, the files are not corrupt, they can be opened in other computers with LibreOffice and also using Excel in the mentioned PC with Windows 11.

I am afraid the problem was triggered after I installed MS-Office on this new machine. I could use LibreOffice for several days before yesterday.

This is the only PC with Windows 11 that I have, brand new, assembled by myself one month ago. MS-Office was the last thing I remember was installed before the issue.

I attached here one of the files, anyway.



RSD_OncoCare.ods (153 KB)

What version of LO are you using (you didn’t say)?

Your file opens fine for me (without crashes) using LO under Windoze.

I already tried with LO 7.2.7 and 7.3.3.

It is not a problem with the .ods files, I tested them on other computers (with Windows 10).

I was working OK with LibreOffice under Windows 11 until yesterday.
I am trying to figure out what I installed in the meantime:

  • Microsoft Office 360.
  • Sumatra PDF
  • 3D Slicer
  • MicroDicom


Something is conflicting with CALC in particular.

If it is just Calc then you could try going to Tools > Options > LibreOffice > OpenCL and unticking Allow use of OpenCL and see if that solves the problem. See Help OpenCL

Other possibilities could be found in First steps to take before submitting a bug - The Document Foundation Wiki

BTW your file opens fine on my PC
Version: (x64) / LibreOffice Community
Build ID: 49f2b1bff42cfccbd8f788c8dc32c1c309559be0
CPU threads: 8; OS: Windows 10.0 Build 22000; UI render: Skia/Raster; VCL: win
Locale: en-NZ (en_NZ); UI: en-GB
Calc: threaded (also set to Calc: CL)

1 Like