LibreOffice Calc - Stops working

This is now happening on both my Windows 10 and Windows 11 computers I can open LibreOffice - a word doc on Windows 11, on Windows 10 the entire application is dead I was going to try to re-install to see if that at least gives me access to Office again, that said, this is now becoming a sadly regular occurrence in that LibreOffice Calc just stops working, this is the first time that I have seen it happening across 2 different computers, I can open a new Calc file (creating it) but then the application stops responding moments later, I have deleted the profile multiple times, no joy. Any ideas I really don’t want to have to move to Office but at this point I cannot have LibreOffice just suddenly stopping to work, I’m on 24.2

Thank you,

On the Windows 10 machine I cannot even open the application any longer it just gets to the splash window and dies there, but again it is 24.2, on the Windows 11 machine it reports as

Please click Help - About LibreOffice. In the dialogue, click the icon with tooltip copy details to clipboard (just after Version information) and paste for each computer into your question. Click the pencil icon to edit your question.

On the Windows 10 machine I cannot even open the application any longer it just gets to the splash window and dies there, but again it is 24.2, on the Windows 11 machine it reports as

I needed more information copied from the About LibreOffice dialogue. Click the icon to copy for the Windows 11 computer.

On the Windows 10 click Start menu > Programs > LibreOffice x.x > LibreOffice (Safe Mode) > Continue in Safe Mode. Does LibreOffice open OK?

What processor (CPU) do you have for each machine?

On the Windows 10 machine

Version: (X86_64) / LibreOffice Community
Build ID: d56cc158d8a96260b836f100ef4b4ef25d6f1a01
CPU threads: 6; OS: Windows 10.0 Build 19045; UI render: default; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

Windows 10 machine

Intel(R) Core™ i5-8500T CPU @ 2.10GHz 2.11 GHz

I’ll provide the Windows 11 information in the morning.

This has an integrated UHD 630 graphics chip. This is the same as mine and I know it will run Skia OK but it works best in Raster mode. It will run Skia in normal mode OK with some minor unwanted effects as long as the graphics drivers are up-to-date. Try updating your graphics drivers first.

  1. Click Start menu > Programs > LibreOffice x.x > LibreOffice (Safe Mode)
  2. In the dialogue, select Configure and Disable hardware acceleration (openGL, OpenCl, Vulkan)
  3. Click the button Apply Changes and Restart
  4. LibreOffice will restart once only without acceleration. When it opens, click Click Tools > Options > LibreOffice > View and under Graphics Output, tick both Use Skia for all rendering and Force Skia software rendering. OK and allow to restart.

If LibreOffice restarts OK then all is well, if it doesn’t restart at the last or earlier step then it might be the result of a corrupted user profile.

Resetting the user profile if the above doesn’t work.
There are several ways to reset your user profile and it is up to you as to what feels most comfortable. I would use the manual procedure and then, after restarting LibreOffice and closing it again, drag most of the folders back to overwrite the newly created ones. This page explains about user profiles and gives different ways of resetting them to resolve corruption, LibreOffice user profile - The Document Foundation Wiki

Windows 10 machine -

When I tried the step, * In the dialogue, select Configure and Disable hardware acceleration (openGL, OpenCl, Vulkan) I was able to open *.odt files, modify, save, etc.,

I also tried to update the video driver on the Windows 10 machine, but for some reason that failed, I ran the Dell Support Assistant, it updated the BIOS, but failed on the Video Driver for some reason. That said when I ran the SA again, it showed no updates at this time.

However, when I tried to open the *.ods file, LibreOffice went unresponsive, even the open odt file locked up, and 2 lock files were created. I deleted the lock files, I was then able to open the odt file again (which actually hadn’t worked before) but again it seems that the ods file(s) are crashing I was going to try to create another one, but at this stage figured what’s the point.

I also did this step LibreOffice will restart once only without acceleration. When it opens, click Click Tools > Options > LibreOffice > View and under Graphics Output, tick both Use Skia for all rendering and Force Skia software rendering. OK and allow to restart. But again works only for the odt files, not ods files (Calc)

I have deleted and recreated the user profile under AppData LibreOffice/4 many times and that really doesn’t seem to have any effect.

Is there anything else that you would like me to try?

Thank you for your assistance in this matter.

(I’ll tackle the Windows 11 at another time)

It might be worth searching the Dell website for updated graphics drivers for your computer. The tool might not be updated for your computer.

After resetting the user profile, you will need to set the Skia options again.

You could try going to Control Panel - Programs and Features, right click LibreOffice and select Repair. This shouldn’t affect settings in the user profile.

Good afternoon,

I attempted to update the graphics driver for my Windows 10 machine and sadly there was/is no change. An *.odt file opens without any issues, while an *.ods still crashes the application. I just kept things as is, opening/closing *.odt files.

I deleted the User Profile, and at that point the application wouldn’t even open. I went back and executed the Safe Mode option, again being able to open *.odt files, only, no *.ods files, I made sure the options were selected as you recommended, but again no joy, *.ods files just crashed the application.

Next I tried all options on another Windows 10 and 11 computer(s) same thing it just seems that the *.ods spoke of the application just keeps crashing the application.

In the end I set up an older SUSE Linux Desktop 12SP4 which runs LibreOffice 6.0.x.x (sorry don’t have the exact version information) all I know is that I was able to open *.ods files modifying/creating, etc., At this point in time I really don’t know if it is a Windows update that is breaking the Calc application, but I really don’t have time to dedicate to this any longer, if the Linux machine is working with the version of software I’ll just use that for now, if you have any other suggestions/recommendations for me to attempt please let me know and I will give that/them a try.

Just a guess: the first versions of LO 24.2.x series were buggy.
You mentioned your vesion as
The newest version is
You should give this a try. This version is much better in terms of bugs…

Is it just opening an .ods file that is the issue?

  1. Can you open Calc only OK?
  2. Can you create a spreadsheet file OK?
  3. Can you Save it OK?

Are you using a third party anti virus? You might need to add LibreOffice as an allowed program; add C:\Program Files\LibreOffice\program\soffice.bin

If it is that Calc crashes on opening, you could try clicking Tools > Options > LibreOffice > OpenCL and untick Allow use of OpenCL but this seems unlikely to be the problem.

Good morning,

I updated to the version - Same results, I can open *.odt files without issues, but when I open a calc file application just locks up, and the associated lock file is created but never deletes itself.

Thank you.

Good morning,

I did the following

Can you open Calc only OK? Yes I can open the application without issue. 
Can you create a spreadsheet file OK? Yes I can create the test spreadsheet. 
Can you Save it OK? Yes I can save it without issue.

However; I cannot open that file after I close Calc. Basically as above it locks the application up, and I have to hit the “X” to exit the software. Then delete the associated lock file.

I do have an anti-malware program running but don’t really see how that would be affecting things, as *.odt files are not affected just the *.ods?

OpenCL is not used - when I go to that area of the application that you recommended.

Thank you,

Hi. My guess is that you have either Avast or AVG anti-virus, that is typical behaviour for them. Maybe they are looking at the components of LibreOffice. This link might help you to manage blocked programs, How to use the Blocked & Allowed apps settings | AVG .

If selecting LibreOffice (Calc?) to unblock doesn’t work, then you will need to add C:\Program Files\LibreOffice\program\soffice.bin to the allowed list

Good day, sadly no on the Avast or AVG, I do have have one process, but I don’t know if that can be adjusted to avoid a particular file structure though I will find out that information, even after the upgrade it is still just the Calc that is not working, which I find really strange, but I just don’t understand why it was working fine for months, at least since Jan, and then stops working. When this last happened I rebuilt the computer but honestly, am not wanting to go to that extreme for just the Calc application when I have at least the Linux option at this time.

Thank you for your help in this matter, if there is anything else you would like me to try please again let me know.

Your anti virus anti ransomware is blocking LibreOffice from accessing files on your drive. An update to it obviously started the issue.

You should find instructions for how to unblock programs on their website. It’s not really a LibreOffice issue but anti virus issue

Version: (X86_64) / LibreOffice Community
Build ID: 51a6219feb6075d9a4c46691dcfe0cd9c4fff3c2
CPU threads: 6; OS: Windows 10.0 Build 19045; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

I uninstalled the AM software and it still made no difference, Calc still wouldn’t function, I also found out that “Formula” is doing the same thing, that said I was also following another thread talking about Calc crashing so it seems that it might be something with Calc in the end. Again Doc, Presentation, DB Drawing all appear to work, basically just Calc is the main issue for me at this time. I can try to do what the other person did, which was went back to a prior version and try that, at this stage I’m pretty much open to trying anything, but since my Linux machine is working, I’ll use it for now.

As above I copied the information from my Windows 10 machine, it reports Calc: Threaded is that something?

Thank you,

Good afternoon, I attempted to use an older version of LibreOffice on a Windows 10 machine that had no applications, not even registered, the first error that came up, “Please wait for Printer Connection or cancel Connection”, as mentioned that machine had nothing no printer, and I was able to get past the error by clicking cancel.

On a Windows 7 machine which is running LibreOffice basically did the same thing when I opened, Calc, it seemed to hang, had to hard exit the application, I noticed that this computer had a Printer that was no longer on my network, when I deleted that Printer, Calc worked, I was able to modify, save, open, in essence I was able to work with Calc again, could this issue really be related to a Printer?

On my Windows 10 machine I removed, my network Printer, brought online a local printer and now Calc is able to open, modify, save create, etc., on my Windows 10 machine. I was going to try to re-add the network printer again to see if things “break” again, but that seems highly dubious that a Printer would stop Calc from working, but I can say now that with having tried this on 3 different machines that really seems to be the common theme, is that the Printer either being in sleep mode like the Network Printer was, or Offline like my Local Printer was, that Calc would basically hang.

Step 1) When Calc hangs, removed Printers or Brought back Online
Step 2) Opened Calc confirmed that application started and was able to modify, create, delete, etc.,
Step 3) Restored Printer (Network) and opened Calc and things were/are working
Step 4) If I come across this again I guess I will try the same thing, removing the Printer(s) and attempting to work through the issues again.

Thank you, for your time and effort on this, it appears again that Calc has/had an issue with the Printer that was also seen in earlier versions of the application.

Thank you, I don’t know if this can be closed as resolved or how that process works, but this should be considered an answer.