LibreOffice headless sometimes crashes under windows 10


I’m testing the conversion process using LibreOffice headless like so:

.\soffice.exe “-env:UserInstallation=file:///C:/Users/ABCDEF/AppData/Local/Temp/lo/89446424-9784-4c03-aa30-e94fb07aba65” --nofirststartwizard --headless --convert-to odt --norestore --writer --outdir “C:\Development\97430a1e-8b0d-4790-b78b-291463b395a6” “C:\Development\97430a1e-8b0d-4790-b78b-291463b395a6\test.docx”

It works most of the time, but sometimes it fails, leaving me with a file called “.~lock.test.odt#” and “lu305764bw6vq.tmp”.

When I check in the “crash” folder of the user installation path, I get this:

Process name: soffice.bin : C:\Program Files\LibreOffice\program\soffice.bin
Exception Code: 0xC0000005
Exception Information: The thread tried to read from or write to a virtual address for which it does not have the appropriate access.

And when I have a look in the event viewer, I get this:

Faulting application name: soffice.bin, version:, time stamp: 0x611afbde
Faulting module name: mergedlo.dll, version:, time stamp: 0x611afbcf
Exception code: 0xc0000005
Fault offset: 0x000000000265c7fe
Faulting process id: 0x95b8
Faulting application start time: 0x01d7ae55ac60ee25
Faulting application path: C:\Program Files\LibreOffice\program\soffice.bin
Faulting module path: C:\Program Files\LibreOffice\program\mergedlo.dll
Report Id: 1e6b484c-dc24-4005-b909-84128999eae1
Faulting package full name:
Faulting package-relative application ID:

I have no idea what’s going on and I can’t get to isolate a specific scenario. I noticed that it seems to happen more often when the UserInstallation path does not exist upfront, however, it also happens when it already exists. I also noticed that it happened more often when converting file located on a network drive.

Note that it seems not to appear when adding the --safe-mode flag.

That suggests that your LO profile is corrupt. Try resetting it.


1 Like

Have a look at:

Well, it happens more often when I start LO with a new user profile. However, it also happens with an existing one so even if it is the issue, there is no solution if it happens with a new or an existing one (solution other than --safe-mode which, so far, never failed).

If you start in --safe-mode, it means that LibreOffice starts with a new user profile.

Ok but how can anything be wrong with a new profile (when I specify -env:UserInstallation to a non existing path).

How do you know you are working with a new user profile? Did you reset to factory settings?
Or did you rename the existing profile?
Have you read the links thoroughly?

If nothing helps, I can only recommend to uninstall LibreOffice completely. Remove all directories to LibreOffice (really all! programs and user directories).
Then reinstall LibreOffice.

I know it because I specify an non existing folder in the -env:UserInstallation parameters and I can see that the folder gets created when I run the command for a first time.

Does LibreOffice have the same issues? I find fewer problems with that release than later releases at the moment so it is the one I currently use for work. Cheers, Al