Libreoffice Impress problem with transparent gifs

So, it’s been bugging me quite a lot. When I add gifs containing transparent backgrounds, it is fine when it is edit mode. But when I start the slideshow, there is a coloured background in place of transparency. I am using MX linux and am using the backports version.
I thought it was a genuine libreoffice bug and had posted a bug in bugzilla. I had later on downloaded the deb file of the Libreoffice Development version 7.2.0 and there I didn’t face this issue. In other words, I am able to see the transparency in the gifs. But the development version crashes quite a bit when I work on it. I want to move to a more stable version from the repos. But this is the only thing that is kind of in my way.
Now, I had installed a forked version of edubuntu via virtual box which had libreoffice (perhaps it was 6.4 or something like that) and there I was surprised to see things working okay i.e. there was transparency in the gifs.
Now I know it is not a MX Linux problem because I have Manjaro as well and there also I face the same issue.
I even tried using Libreoffice from flathub. I get the same result i.e. the gifs have a flashing coloured background.
What is happening? What settings should I change to make it work?

Here’s the gif I used:

Here are the screenshots of the slideshow:

Here’s the odf file:

Version: / LibreOffice Community
Build ID: a529a4fab45b75fefc5b6226684193eb000654f6
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

[Enabled image - please use Slide icon]

Please upload an ODF type sample file here.

I’ve uploaded the ODF file.

Your sample file works for me as you expected in my LO 6.1.6 x64 permanantly installed, and in my LO 7.1.4 x86 Portable versions on Windows 10 Prof x64 - in edit mode and in Slide show mode too

If so, then what seems to be the issue? How can I resolve it?

I’m currently using LO 6.1 where the gifs work as expected, but why is it that gifs don’t seem to work on versions after that on my PC?

On LO 7.2 Development Build, the gif again works as expected. So, what is wrong with all the versions in between? Is it something to do with my hardware? If so, if I change some settings, will it work?

@bugs - The example file works as expected for me, too. Both images are transparent. That indicates whatever’s causing it is something with your computer. Have you checked to see if your graphics drivers and operating system is up to date? Do you have any accessibility options turned on anywhere? Any 3rd party tools or utilities running? My guess is it’s a setting somewhere that’s doing it. I don’t think and highly doubt it’s hardware.

OS LinuxMint 19.3-64 Mate

LO and

In LO a non-transparent rectangle surrounded the animated GIF.

In LO the animated GIF worked as desired.

Try an update.

Downloaded the AppImage and nope. The problem still persists.
There is a non-transparent rectangle surrounding the gif.

And even before this, I was using the same version ( from flathub and there also the problem continued. :frowning:

And here’s something else. I was testing each LO version via appimage and then finally when I reached 6.1, the gif worked normally. So, for the time being, I’ve downloaded the deb files of LO 6.1 and have installed it.
But I would so like to use the recent version.

@bugs - AppImage

I wonder why you use the Appimage version. Advantage? I always install as parallel (but latest version via PPA: ppa:libreoffice/ppa) - so latest version is standard app.

If you are accustomed to above mentioned procedures it is really easy to have several stable versions - and the latest version is always updated…

I used Appimages to see if gifs work normally on it. When I came across LO 6.1.6 where gifs worked as expected, I removed the appimage and downloaded the deb files.

Right-Click on the image in Impress and select Edit Style.

image description

When the Styles dialog appears open the Area tab and make sure None is selected as the area background option.

image description

There was a layer in all the frames of the animation that was active that shouldn’t have been. It’s what was making his feet look weird and his hair poof up. I corrected that. Here is the new file.

image description

If you wanted that effect in the animation I apologize. Use the original image. The area style is probably what’s causing the background in it.

This was one of the first things I tried. And nope. None is already selected.

@Bort - I had downloaded the GIF and checked via GIMP. I did not find any superfluous layer. So I did not wonder that the latest LO version showed the desired result.

Probably LO interprets the transparent “layer” (i.e. transparency of each layer) in the wrong way. This could explain your result in altering the original GIF.

Okay. But in that case, it should be the same for the same version of LO but in another system, isn’t it? In other words, an LO bug. Here, for some, the gifs are read properly and for other it isn’t read proeprly even though they both are using the same version of LO.
And like I noticed, on my system, when I download an older version of LO (6.1.6), it works. But it doesn’t work in versions that come after it until we reach LO 7.2 Development build.
What’s bugging me here is the inconsistency.
As in, one cannot say that it is an LO bug because it works for some while it doesn’t work for others.
And on the other hand, one cannot say that it is a user-specific problem (as in general settings or video driver issues or something like that) because this is faced by users using different distros.