Libreoffice not recognizing courier (or Nimbus Mono) on Linux/KDE Plasma


Hi all,

I’ve a similar issue like this: LibreOffice not recognizing Courier, except that I’m using LibreOffice on Linux (OpenSuse 42.3, KDE/Plasma 5.8.7).

Just recognized that “Courier” font has “gone”. I’ve some older LO docs where I could use it (shown in italic in font box, displayed correctly in text) , but for new docs it’s not shown as available anymore.

Strange as this is, KDE’s system settings shows “Courier” and “Courier 10 Pitch” as available.

The other question advices to use “Nimbus Mono” as free alternative, same thing: Shown in KDE as available, not shown in LO.

Any hints would be great :slight_smile:

Thanks in advance,

Just got an IRC answer from #SUSE:

  • simply type “Courier” in the font box,
  • press return
  • and, magically, the font is NOW available.

Ugly workaround, but at least a workaround.

Nevertheless I’m still interested in some infos about the “official” link between system fonts and fonts in LO.