LibreOffice opens, but writer, calc, and base are greyed out, though installed

Present:. Using libreoffice v. on an updated Ubuntu variant (Tuxedo OS), Tuxedo laptop. I can open libreoffice, but not writer, calc, or base, which options are greyed out on the libreoffice open screen. Only Impress, Draw, and Math Formula are active and available. If I click on an odt file created previously in Writer, it opens the libreoffice window but not the file, showing instead a filter screen asking me to select a file format, but odt is not offered as an option, only formats that will open in Impress and Draw. The same if I try to open a file from the libreoffice window, it shows the same filter screen.

I have used libreoffice for many years, almost daily, since it forked from openoffice, and have many thousands of files created during that time.

History of problem: I tried to change a default keystroke shortcut in libreoffice (from within the program itself, not knowing which file it would be found in), and it corrupted the keystroke shortcuts.

So I uninstalled and reinstalled libreoffice. It still didn’t work. So I deleted the libreoffice config files in my home directory and in /etc, then uninstalled and reinstalled.

And now I’m in this situation where Writer, Base, and Calc are all installed, but they will not open nor are their file formats recognized by libreoffice. I’ve uninstalled and reinstalled multiple times, but though they are installed, they are utterly unavailable. I have removed the config files again (rm -r .config/libreoffice/4/user/*), but no improvement. I have opened libreoffice in safe mode and one by one done all the options given there, but still the same problem.


How did you install? With command apt-get or one of its GUI frontends? Or did you load from

I installed from a gui front end – both an “app store” called Discover that’s part of the distro, and also by synaptic package manager (also gui, but more powerful). That is, in the multiple uninstalls and installs, I tried each at different times.

Then you have a version compatible and tested with your distribution.
In my Fedora distro, LO is split into multiple packages so that a “selective” installation can be made. Have you done so or loaded all packages?

To make sure, create another user (so that its config directories are “clean”). Log in under this new user. Launch LO. Can you use Writer?

Thank you. I’ll do that. As to the question, I installed both ways – first by a meta-package installation, which didn’t work, then after uninstalling, I tried the individual packages, and added all that were suggested, but that didn’t work either. Again, I’ll try your suggestion, but won’t be back here till tomorrow as it’s night here in France. Thanks.

Went ahead and added another user, and exactly the same problem under the new user. So at least I know now that it isn’t any config file in my home directory that is causing the problem but something in the system installation. I’ll try again by deleting the installation, and then I’ll try installing through apt. If that doesn’t work, I’ve downloaded the latest version (7.5) from the website, though that I know has its own risks, since it hasn’t been vetted and added to the distro’s repositories. But I’m ready to try anything (almost), as long as I’m pretty sure I can undo it.

See also: don't need impress or calc - #6 by mikekaganski

After uninstalling all libreoffice-specific packages once again, I just did a partial install with apt-get, and writer works fine now. I’ll add other packages (Impress, Calc, Base, Math, different language packs that I use, thesauruses and hyphenation dictionaries) to make a fully functional office suite, but installing related packages at a time, and then test again after each install.

Though I said I wouldn’t be back till tomorrow, couldn’t stop. So I installed the other packages with apt-get, and did an apt autoremove, and all works like a charm.

1 Like