LibreOffice Writer export pdf does not embed fonts

I have a fresh install of Lubuntu 20.04. I have installed LibreOffice When I export directly as pdf, the document produced is smaller pdf file than the original odt file. Furthermore, using command line pdffonts .pdf shows that there are no exported fonts. If I open the file with qpdfview, the file is blank.

Next, if I use the command line: libreoffice --export-to pdf .odt, it produces a file .pdf of the proper size. When I use the pdffonts command as above, it shows the proper embeded font. If I open the file with qpdfview, the file is displayed properly.

It does not matter what font is used: Liberation Serif, Times New Roman, etc.

Is this a bug?


Please choose File - Export As - Export as PDF, General tab and verify this option:


I tried this option, but it stil does not work…
For testing purposes, I modified my form to use “Liberation Sans” font for a few text area fields.

When I launch pdffonts, I can see the new font… but not embedded !

name                                 type              encoding         emb sub uni object ID
------------------------------------ ----------------- ---------------- --- --- --- ---------
BAAAAA+DejaVuSans-Bold               TrueType          WinAnsi          yes yes yes     15  0
CAAAAA+DejaVuSans                    TrueType          WinAnsi          yes yes yes     20  0
LiberationSans                       TrueType          WinAnsi          no  no  no      22  0

Any suggestion ?

@KevinR, JohnSUN is correct, check this option when using that option.

image description

I am no expert at all. Just I also had this problem in Lubuntu 20.04 with LibreOffice 6.4.x. The solution provided by @wxl in Lubuntu forum (Printing problem with 20.04) worked smoothly for a while to me and suddenly, out of the blue, it stopped exporting PDF. Then I found this solution in another post here in Ask LibreOffice and now I am back on the road! It can help you momentarily until we figure out what is really happening.

My suspect is LibreOffice ;D

AskLibreOffice :: Cannot print anything…