LO 24.2: opening DOCX in Writer hangs the LO

Hello all,

I’ve a problem opening DOCX files with LO 24.2 - it simply hangs the Writer and do nothing.
Other document types (DOC, ODT) works well.

Tried: opening via LO Writer, LO in safemode, resetting to defauts, right click on DOCX file and open, reinstalling software, disabling AV.
Curiosity: it is possible to create a few lines of text in Writer, then save it as DOCX (2007 of 2010-365 format), but it can’t be opened again by Writer.

Running Win11 Home (Polish)
Affected versions of LO: 24.2.1 (also the PortableApps version), 24.2.2, (both have Polish localization installed)
LO 7.6.5 works flawlessly, so I’ve temporarily downgraded the LO.

I have saved one file in 2007 and one in 2010 DOCX format.
I can open both files again without any problems.

103914 LO 24.2 - opening DOCX in Writer hangs the LO 2007.docx (5,6 KB)
103914 LO 24.2 - opening DOCX in Writer hangs the LO 2010.docx (5,6 KB)

Version: (X86_64) / LibreOffice Community
Build ID: db4def46b0453cc22e2d0305797cf981b68ef5ac
CPU threads: 8; OS: Windows 10.0 Build 19045; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL threaded

Is this behavior with all DOCX files or only with some of them?

And please state the operating system you are using. Thank you.

If possible, please upload a file here for testing. Thank you.
And please remember, this is a public place here.

The issue concerns all DOCX files and this type - XLSX opens correctly. Opening DOCX hangs the Writer - no matter where they come from: they are my old files, documents from colleagues, etc. So I did this experiment to create a DOCX document in LO Writer 24.2 and then open it - well, it doesn’t open documents created by itself.

There’s no point in uploading files here, as yours doesn’t open either, and I’m unlikely to have a starting point for further analysis.

The system is Windows 11 23H2 (22631.3296). Interestingly, LO 7.6.5 works flawlessly on the same platform.

I realise that it may be difficult to find a solution, as version 24.2 works fine on a Windows 10 PC ( a portable version, to be honest), so it looks like the issue is operating system related.

After many hours of battle, I managed to solve the problem and now this thread can be closed. The cause was an unavailable network printer. After deleting the unavailable printer and assigning permanently another printer as default, everything worked.