LO Base Reports won't open: JavaLoader error or jFreeReportBoot error

I am having a java problem specifically with Base reports in OpenSuse 13.2 (Linux). I can create and edit reports, but when I try to open them, I get a java error.

With LO Version: (Build ID: 430m0(Build:2)), when I try to execute or open the report, I receive an error message that the report cannot be opened because of a javaloader error -- could not find class com/sun/star/com/loader/JavaLoader/.

image description

I previously had been using the factory LO version, 4.4, where I got a different, longer error message about jFreeReportBoot. The error in LO 4.4 was not resolved by installing jCommon. EDIT: I get two error messages, first the one on top, then on subsequent attempts to open, I get the one below.

LO 4.4 err msg 2

Looks like I am missing a dependency or need to change something in the java configuration, but the error messages do not provide instructions. I am using OpenJDK 1.8, with nothing manually entered into the LO class path.

EDIT: On a recent reinstall, I got an option to run a JRE environment 1.5 provided by the Free Software Foudation. That generates the error message below:

LO 4.4 JRE Free Sofware Found 1.5

Last I downloaded the LO 4.4 binaries from a non-repo source. There are some serious rendering artifacts in that instance (bad painting of menus, mostly) that overall make it unusable. The reports do open with no popup box with the non-repo binaries, but in the terminal it receives output:

WARNING: Exception while loading module: org.pentaho.reporting.libraries.base.boot.DefaultModuleInfo={ModuleClass=org.jfree.report.modules.gui.swing.common.SwingCommonModule}
        at org.pentaho.reporting.libraries.base.boot.PackageManager.containsModule(PackageManager.java:369)
        at org.pentaho.reporting.libraries.base.boot.PackageManager.loadModule(PackageManager.java:436)
        at org.pentaho.reporting.libraries.base.boot.PackageManager.addModule(PackageManager.java:330)
        at org.pentaho.reporting.libraries.base.boot.PackageManager.load(PackageManager.java:199)
        at org.jfree.report.JFreeReportBoot.performBoot(Unknown Source)
        at org.pentaho.reporting.libraries.base.boot.AbstractBoot.start(AbstractBoot.java:197)
        at org.libreoffice.report.pentaho.PentahoReportEngine.<init>(PentahoReportEngine.java:34)
        at org.libreoffice.report.pentaho.SOReportJobFactory$_SOReportJobFactory.createReportJob(SOReportJobFactory.java:318)
        at org.libreoffice.report.pentaho.SOReportJobFactory$_SOReportJobFactory.execute(SOReportJobFactory.java:212)

I’m out of ideas. Maybe a OpenSuse package manager problem? Suggestions?

Java version ?

JRE reported by LO to be vendor: Oracle Corporation version: 1.8.0_40. As stated, this is OpenJDK. Also tried activating JRE verison 1.7.0_75. Those are the packages provided by the community OpenSuse repos.

You could try installing Oracle Java SE 8 instead. However, much to my surprise, it’s weird how much is left up to the SysAdmin to install stuff that can’t be found in the repos. On Ubuntu, almost everything are automated by way or another, so installing Oracle Java SE is as easy as installing any package. Or, you could try updating LO.

No improvement after manually installing JRE for Linux v8 update31 from java.com and activating the JRE environment in LO.

Ok, try updating LO. If you can’t update it, you could download LO from their site for Linux and run the binary, assuming there’s one.

Tried the binaries. Per edits, this problem does not exist in the LO direct-download binaries, but that instance has separate bad rendering problem. Any ideas for getting the community repo version to work?

Was missing a dependency, pentaho-reporting-flow-engine which installed a bunch of other dependencies. I guess that is the renamed jFreeReport according to the description.

not resolving the dependency automatically seems like someone’s bug. I don’t know whose.