LO can't see my fonts (Windows 7)?

After installation there are only dash-like lines instead of letters and words in my LO. So, obviously it can’t see my fonts for some reason. And I’m using Windows 7 and all my fonts are in %windir%/Fonts. Let’s make LibreOffice great again, guys!


So many hours have passed and there’s still no single answer to my issue. It looks to me like no one wants to make LibreOffice great again. It’s very sad.


Windows 7 Ultimate x86 SP1, LibreOffice

I tried to reset the user profile by renaming the existing user folder in %appdata%\LibreOffice or deleted the LibreOffice folder completely.
I renamed the file extensions.pmap (there was no extensions.db) in /user/extensions/bundled/

Nothing of the above was helpful.

I also tried portable version of the program (link is below). I even tried to put fonts in LibreOfficePortable\Data\fonts (the folder for additional fonts). But the problem remained.

LibreOffice 5.3.4 Portable MultilingualStandard:

What else could I try?

11 hours ago

So many hours have passed

My goodness, make LO users great again. What Windows? Home, prof, …? 32 or 64 bit? What LO version did you install? 5.2.x, 5.3.x? 32 or 64 bit?

What could have happened? Probably you got a corrupted office profile. Rename or erase it and start anew (if you run LO quickstarter so shut it down as well).

If the reason of your problem is not solved by the above written step you have to look for graphics properties. In case that LO denies plotting the fonts you have to alter Windows graphics properties.
In case that LO shows rudiments of fonts click Tools menu… Memory or OpenCL. Maybe some change is successful.

Hope you’ll get great again on my hints.

Finally someone answered. Thank you very much, Grantler.

Yes, probably. But I had already tried deleting it and it didn’t help. Just to avoid any misunderstanding I’m talking about this folder:

I’m on Windows 7 Ultimate SP1 x86. About Windows 7 it was clearly stated in my initial post, but I thought that that additional information was not really relevant to my problem, so I omitted it, But you might be right and I shouldn’t have. The version is 5.3.

And unfortunately I cannot click and edit anything in menu because I can’t see it.

@Grantler, in my update #2 I provided some more information. I hope you’ll be able now to come up with something that’ll finally help us to make LibreOfiice great again!

My next step would be: Downgrade to LO 5.2.x (still available) or try out OpenOffice. Probably a portable one would do.
In some versions you can check/uncheck hardware/graphics acceleration (Tools menu > OpenOffice > View :: Graphics output > hardware acceleration). But you have to see the fonts before, without - it won’t be possible to do that.

If there will be the same problems you are forced to alter Windows graphics properties… In this case I am not able to give any advice.

OpenOffice had been installed on my computer even before I tried LibreOffice, and there wasn’t any problems with it. I know the two programs are almost identical, but for some reason I wanted to try LO.

Portable version of LO v5.3.4.2 as I said earlier had the same font problem.

Yes, I didn’t try turning off hardware/graphics acceleration or to make any other changes to the graphic properties for the reason you mentioned. But thank you for the tip anyway.

@Grantler But most importantly, thank for suggesting me to downgrade to 5.2.x (Still) version. It has no problem on my computer. I guess I’ll stick to this version then for a while.

Thank you very much for your help, Grantler. I do appreciate it. Cheers.

i have had the same problem with LO 5.3.4 and solved it downgrading, now i tried 5.4.2 but still not working properly.
i have w7 home premium 64bit
i’m reinstalling 5.2.6 but i’m afraid it might be unsafe(?)
any suggestion welcome

I have just had the same issue with an old .odt containing specialized fonts on a fresh install of 5.4.5 on an also-fresh Win7 Pro install. Fonts weren’t showing nor listed despite being installed and the doc looked like garbage. Thankfully, while scratching my head I managed to find this thread. As soon as I nuked LO 5.4.5 and installed, my fonts were instantly back in Writer. I sure hope this issue gets some attention, but as a Win7 issue I’m not sure it will.